Roadwarrior not starting..



  • Hi all !!

    I'm pretty new to this product openVPN but are fairly experienced in general networking.

    I've managed to set up an site 2 site vpn tunnel and all is  working as it should
    with some dns and wins stuff i can also browse the LAN on the other side of the tunnel fine !

    to the problem: roadwarrior setup

    I've read the forums and are using the GUI version of the client (latest).
    Running vista as the client.

    I have followed the dummies roadwarrior setup twice but it will not run.

    Questions:
    Under 32
    it says "Source: LAN (or whatever the name of the net defined in #22 'address pool' is)"
    If i choose LAN the then the field to put my adresspool for the RW client is greyed out.
    There i choose source network and manually added my address pool. Is that right !!??

    In the documentation about open vpn GUI it says that you should right click the GUI icon and
    have the options to connect or disconnect. The are no choices when i right click !

    Here are my logfile:

    Sep 5 10:26:20 openvpn[98736]: event_wait : Interrupted system call (code=4)
    Sep 5 10:26:20 openvpn[98736]: /etc/rc.filter_configure tun0 1500 1542 192.168.100.1 192.168.100.2 init
    Sep 5 10:26:21 openvpn[98736]: SIGTERM[hard,] received, process exiting
    Sep 5 10:26:22 openvpn[384]: OpenVPN 2.0.6 i386-portbld-freebsd6.2 [SSL] [LZO] built on Sep 13 2007
    Sep 5 10:26:22 openvpn[384]: WARNING: file '/var/etc/openvpn_server0.key' is group or others accessible
    Sep 5 10:26:22 openvpn[384]: gw 194.xxx.xxx.xxx
    Sep 5 10:26:22 openvpn[384]: TUN/TAP device /dev/tun0 opened
    Sep 5 10:26:22 openvpn[384]: /sbin/ifconfig tun0 192.168.100.1 192.168.100.2 mtu 1500 netmask 255.255.255.255 up
    Sep 5 10:26:22 openvpn[384]: /etc/rc.filter_configure tun0 1500 1542 192.168.100.1 192.168.100.2 init
    Sep 5 10:26:23 openvpn[399]: UDPv4 link local (bound): [undef]:1194
    Sep 5 10:26:23 openvpn[399]: UDPv4 link remote: [undef]
    Sep 5 10:26:23 openvpn[399]: Initialization Sequence Completed

    I get a warning message above and don't know what it means !

    Can anyone help out !

    The Wizard



  • I rebooted the FW to get a clear log, here it is:

    Sep 5 10:57:38 openvpn[309]: OpenVPN 2.0.6 i386-portbld-freebsd6.2 [SSL] [LZO] built on Sep 13 2007
    Sep 5 10:57:38 openvpn[309]: WARNING: file '/var/etc/openvpn_server0.key' is group or others accessible
    Sep 5 10:57:38 openvpn[309]: gw 194.xxx.xxx.xxx
    Sep 5 10:57:38 openvpn[309]: TUN/TAP device /dev/tun0 opened
    Sep 5 10:57:38 openvpn[309]: /sbin/ifconfig tun0 192.168.100.1 192.168.100.2 mtu 1500 netmask 255.255.255.255 up
    Sep 5 10:57:38 openvpn[309]: /etc/rc.filter_configure tun0 1500 1542 192.168.100.1 192.168.100.2 init
    Sep 5 10:57:38 openvpn[320]: UDPv4 link local (bound): [undef]:1194
    Sep 5 10:57:38 openvpn[320]: UDPv4 link remote: [undef]
    Sep 5 10:57:38 openvpn[320]: Initialization Sequence Completed
    Sep 5 10:57:39 openvpn[320]: Need IPv6 code in mroute_extract_addr_from_packet
    Sep 5 10:57:39 openvpn[322]: OpenVPN 2.0.6 i386-portbld-freebsd6.2 [SSL] [LZO] built on Sep 13 2007
    Sep 5 10:57:39 openvpn[322]: WARNING: file '/var/etc/openvpn_client0.secret' is group or others accessible
    Sep 5 10:57:39 openvpn[322]: gw 194.xxx.xxx.xxx
    Sep 5 10:57:39 openvpn[322]: TUN/TAP device /dev/tun1 opened
    Sep 5 10:57:39 openvpn[322]: /sbin/ifconfig tun1 192.168.0.2 192.168.0.1 mtu 1500 netmask 255.255.255.255 up
    Sep 5 10:57:39 openvpn[322]: /etc/rc.filter_configure tun1 1500 1546 192.168.0.2 192.168.0.1 init
    Sep 5 10:57:40 openvpn[320]: Need IPv6 code in mroute_extract_addr_from_packet
    Sep 5 10:57:40 openvpn[333]: Attempting to establish TCP connection with 194.xxx.xxx.xxx:1193
    Sep 5 10:57:40 openvpn[333]: TCP connection established with 194.xxx.xxx.xxx:1193
    Sep 5 10:57:40 openvpn[333]: TCPv4_CLIENT link local: [undef]
    Sep 5 10:57:40 openvpn[333]: TCPv4_CLIENT link remote: 194.xxx.xxx.xxx:1193
    Sep 5 10:57:41 openvpn[333]: Peer Connection Initiated with 194.xxx.xxx.xxx:1193
    Sep 5 10:57:41 openvpn[333]: Initialization Sequence Completed
    Sep 5 10:57:42 openvpn[320]: Need IPv6 code in mroute_extract_addr_from_packet



  • Hi all !!

    solved the problem myself. all is working now

    The Wizard


Locked