Cp with custom login site



  • Hey,

    I read a lot about this topic, and tried a lot, but it does not work.

    I am using pfsense 2.3.2-RELEASE-p1 (amd64)

    I Uploaded with file manager some files.

    Then I created a simple html file:

    
    	![nothing](captiveportal-test.png)
    
    

    Firefox shows me "nothing" and not the picture.

    This is a simple test. I have a site with css files, but the css files are not loaded. I checked file names in my html file.

    I tried to download this picture directly with wget:

    wget http://192.168.3.1:8002/captiveportal-test.png but I get every time html file.

    
    root@test:~# wget -S http://192.168.3.1:8002/captiveportal-test.png
    converted 'http://192.168.3.1:8002/captiveportal-test.png' (ANSI_X3.4-1968) -> 'http://192.168.3.1:8002/captiveportal-test.png' (UTF-8)
    --2016-10-31 09:50:57--  http://192.168.3.1:8002/captiveportal-test.png
    Connecting to 192.168.3.1:8002... connected.
    HTTP request sent, awaiting response...
      HTTP/1.1 200 OK
      Server: nginx
      Date: Mon, 31 Oct 2016 08:50:57 GMT
      Content-Type: text/html; charset=UTF-8
      Transfer-Encoding: chunked
      Connection: close
      Expires: 0
      Cache-Control: no-cache, no-store, must-revalidate
      Pragma: no-cache
      X-Frame-Options: SAMEORIGIN
    Length: unspecified [text/html]
    Saving to: 'captiveportal-test.png'
    
    captiveportal-test.png                                           [ <=>                                                                                                                                           ]      99  --.-KB/s   in 0s
    
    2016-10-31 09:50:57 (18.8 MB/s) - 'captiveportal-test.png' saved [99]
    
    root@test:~# file captiveportal-test.png
    captiveportal-test.png: HTML document, ASCII text
    
    

    I enabled direct file logging for captive portal nginx, I see, that the picture file is requested:
    192.168.3.51 - - [31/Oct/2016:09:47:38 +0100] "GET /captiveportal-test.png HTTP/1.1" 200 107 "http://192.168.3.1:8002/?zone=wifi_open" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0"

    Is this a bug or do I configure anything wrong?

    viele Gruesse,
    thomas

    ![Screen Shot 2016-10-28 at 15.34.33.png](/public/imported_attachments/1/Screen Shot 2016-10-28 at 15.34.33.png)
    ![Screen Shot 2016-10-28 at 15.34.33.png_thumb](/public/imported_attachments/1/Screen Shot 2016-10-28 at 15.34.33.png_thumb)



  • Well, have you checked the source in your navigator ?
    Btw, what does firebug / inspect element say ?

    Also, you might check with a .php extension instead of html.

    At last, maybe add at least the minimum required CP code, for testing purposes.

    Good luck.


Log in to reply