Gelöschte Regel greift nicht richtig



  • Hallo,

    ich lege eine neues Interface ( zb. mit dem Namen OPT8 und der IP 10.1.105.254/24 ) an und starte darauf einen DHCP-Server. Nun hänge ich einen DHCP-Client an das Interface und lasse ihn eine IP ziehen. Geht natürlich nicht, genau so wenig wie Pings, weil noch keine Regeln erstellt wurden.

    Nun lege ich zum Test auf OPT8 eine Regel an, die jeglichen Traffic überall hin erlaubt, also folgende:

    Proto *  Source *  Port *  Destination *  Port *  Gateway *  Schedule *

    Nun hänge ich den Client wieder ins Netzwerk von OPT8 und lasse ihn eine IP ziehen. Funktioniert auch! Er zieht sich eine IP aus der für OPT8 definierten Range.

    Wenn ich aber die Regel wieder lösche, kann der Client weiterhin eine IP ziehen und Pings funktionieren auch noch, obwohl eigentlich garnix passieren dürfte. Anderer Traffic, zb. DNS-Anfragen, TCP-Verbindungen etc gehen nicht mehr.

    Warum?

    Gruß

    mafi

    PS: Was ich eigentlich schon die ganze Zeit versuche ist, nur DHCP-Traffic auf OPT8 zuzulassen. Bekomms aber nicht hin. Wie muss die Regel dafür aussehen ?
    PPS: Wie kann man DHCP-Leases löschen ?



  • Statefull Firewall maybe?! Lösche einmal die States und teste noch einmal

    Regards
    Heiko



  • Nee, bringt genau so wenig wie ein ein Reboot - hatte ich schon getestet. Lässt sich auch leicht nachstellen, auf der sense muss nichts konfiguriert sein.

    Ich nutze 1.2 Final.

    Ich nehme an, dass dieses Sympthom weg geht, wenn die lease-Tabelle  gelöscht wird. Nur wie lösch ich sie?

    Die Frage nach der Ursache bleibt aber noch. Selbst wenn ich eine Regel für das Interface definiere, die explizit jeglichen Traffic blockt oder zurückweist, klappt die DHCP-Anfrage des Clients weiterhin! Könnte dieser Bug auch bei anderen pfsense-internen Deamons vorhanden sein und weiterhin Traffic durchlassen?


Locked