PfSense Authentifizierung am AD funktioniert nur teilweise



  • Hallo zusammen,

    ich wollte mal nachfragen, ob ihr eventuell mehr wisst.
    Ich habe auf der Seite System -> User Manager -> Authentication Servers meinen AD Server hinzugefügt und die entsprechenden OUs als Container hinzugefügt.
    Dann habe ich wie in einigen Tutorials beschrieben eine Gruppe pfSenseAdmins angelegt (im AD und auf der pfSense).
    Mein Useraccount ist in der Gruppe drin.
    Gehe ich nun System -> User Manger -> Settings und speichere das AD und versuche über Diagnostics -> Authentication meinen Account einzuloggen, sagt er zwar, dass ich authentifziert werden konnte, aber er sagt nicht, dass ich in irgendwelchen Gruppen bin (obwohl ich das ja eigentlich bin).
    Wenn ich versuche, mich direkt im Webinterface einzuloggen, geht das zwar aber er sagt mir dann, das mir keine Seiten zugewiesen sind.

    Wer kann helfen?



  • Hallo,

    damit du die WebGUI nutzen kannst, musst du deinem Nutzerkonto unter "Effective Privileges" die entsprechenden Seiten zuweisen, oder das Konto zur lokalen Gruppe Admin hinzufügen. Diese Gruppe hat von Haus aus Zugriff auf alle Seiten.



  • Ja genau das habe ich ja versucht. Einen AD Benutzer kann ich ja lokal nicht anlegen, deshalb lege ich ja eine entsprechende Gruppe auf der pfSense und im AD an.
    Aber genau das funktioniert irgendwie nicht.

    EDIT:
    Also habe jetzt folgendes herausgefunden: Der Benutzer im AD darf nur eine Gruppe haben und das muss die Gruppe sein, die auch in pfSense als Gruppe angegeben ist.
    Also nehme ich doch die lokale Benutzerdatenbank von pfSense, weil wenn ich nen extra Benutzer für pfSense im AD anlegen muss, kann ichs auch bleiben lassen.



  • Das hast Du falsch verstanden. Viragomanm meinte wohl, dass Du der Gruppe ( und damit den in der gleichnamigen Gruppe im AD enthaltenen Usern )  im User-Manager bei Groups unter "Assigned Privileges" Zugriff auf die entsprechenden CP-Seiten geben musst.


Log in to reply