PLEX + pfSense idle connection problem



  • Hallo zusammen,

    ich habe ein kleines Problem mit dem PLEX Media Server und pfSense.

    Ich habe hier im Hause zwei Netzwerke, pfSense dient als Router zwischen diesen beiden. Das läuft auch soweit auch alles tadellos, allerdings bricht die Verbindung zum PLEX Server auf Port 32400 nach einigen Sekundne oder auch Minuten (je nachdem ob ein Film läuft oder eine ein Lied) ab, soweit ich sehe weil pfSense idle connections schließt.

    Greife ich direkt auf den PLEX Server zu ohne das pfSense routet, kommt das Problem nicht vor.

    Als ersten Workaround habe ich unter Advanced -> Firewall Optimization Options von "normal" auf "conservative" gestellt, das hat schon viel geholfen, es kommt aber immer noch vor, es aber dauert aber länger bis es auftritt. Stelle ich übrigens auf "aggressive" verstärkt sich das Problem wie erwartet. ("High latency" bringt kein Besserung)

    Kennt jemand das Problem bzw. hat jemand eine Idee wie das dauerhaft zu lösen ist? Es mag auch sein, daß ich das Problem eher im PLEX Forum posten sollte, das fällt mir schwer einzuschätzen.



  • Hallo,

    also wenn es am Timeout liegt, das lässt sich beliebig einstellen.

    Dazu musst du die Regel editieren, die diese Verbindung erlaubt. Am besten hast du also eine eigene Regel, die Port 32400 TCP erlaubt.
    Unten auf "Advanced options" klicken, damit diese angezeigt werden. Dann kannst du bei "State timeout" den gewünschten Wert in Sekunden eintragen und das Ganze speichern.



  • Hallo,

    vielen Dank für die prompte ANtwort. Werde es ausprobieren und dann umgehend berichten.



  • Hallo nochals,

    das war auf jeden Fall die richtige Spur, letztich habe ich wie hier beschrieben eine entsprechende floating rule für den Port 32400 gesetzt, damit ist das Problem auf jeden Fall gelöst:

    https://doc.pfsense.org/index.php/Asymmetric_Routing_and_Firewall_Rules

    Zwar funktioniert es jetzt, ich befürchte aber, das Problem ist generell einem falschen Aufbau meines Netzwerks geschuldet, ich versuche daher noch, das Problem auf andere Weise zu lösen.


Log in to reply