WebConfigurator Port 8443 Already Bound [FIXED]



  • I tried to change the port on the web page to use an alternative port 8443. On restart, the webconfigurator was unavailable. I ssh'd in to the server and use option 11 to restart, but get the following:

    pfSense nginx: 2016/11/07 21:37:02 [emerg] 29637#101359: bind() to 0.0.0.0:8443 failed (48: Address already in use)

    I have pfblockerng and guess that is using the port. I can't see how to change the web configurator port to another port now as I can't access the gui. I have tried to change config.xml in /conf/config.xml and trying option 11 again but it complains about 8443 again.

    Does anyone know which file to change to restart the web configurator on a different port?



  • Fixed it - editing the file /conf/config.xml is correct

    However, I had to delete /tmp/config.cache and restart the gui to make it pick up the changes.


Log in to reply