Captive Portal - nginx Bad Gateway 502



  • Olá Pessoal,

    Estou com o PFSense 2.3.2-RELEASE-p1 (amd64) onde configurei Captive Portal + freeRadius (+LDAP) + Squid (Transparent) + SquidGuard.

    Criei um php personalizado para autenticação no Captive Portal e fiz upload. A autenticação funciona normalmente e a navegação fica liberada após, mas em determinados momentos algumas tentativas de login aparece a mensagem, assim como para acessar o WebConfigurator:

    502 Bad Gateway - nginx

    Alguém poderia me ajudar?

    log System - General em anexo

    Obrigado
    ![nginx log.JPG](/public/imported_attachments/1/nginx log.JPG)
    ![nginx log.JPG_thumb](/public/imported_attachments/1/nginx log.JPG_thumb)



  • I see a lot of "login errors" etc.
    Can you clear that first ?
    Things will be easier to understand afterwards, you'll see ;)

    If not => go here : Español



  • Hello Gertjan, thanks for your reply!

    I discovered the issue, I had enabled the following options in Captive Portal settings:

    • Reauthentication - Reauthenticate connected users every minute

    • RADIUS MAC Authentication - Enable RADIUS MAC authentication

    So, when I disabled them, the php-fpm service decreased the CPU usage and now everithing is fine!

    Regards


    Olá Gertjan, obrigado por responder!

    Eu descobri o problema, eu tinha habilitado as opções abaixo nas configurações do Captive Portal:

    • Reauthentication - Reauthenticate connected users every minute

    • RADIUS MAC Authentication - Enable RADIUS MAC authentication

    Então quando desabilitei, o serviço php-fpm diminui o consumo de CPU e agora está tudo funcionando!

    Abraços


Log in to reply