MLPPP



  • Is anyone else having this issue with getting the second link up and going. Here is my 100 lines from log:

    Nov 10 18:19:49  ppp  [wan_link0] LCP: authorization successful 
    Nov 10 18:19:49  ppp  [wan_link0] Link: Matched action 'bundle "wan" ""' 
    Nov 10 18:19:49  ppp  [wan_link0] Can't join bundle wan without multilink negotiated. 
    Nov 10 18:19:49  ppp  [wan_link0] link did not validate in bundle 
    Nov 10 18:19:49  ppp  [wan_link0] LCP: parameter negotiation failed 
    Nov 10 18:19:49  ppp  [wan_link0] LCP: state change Opened –> Stopping 
    Nov 10 18:19:49  ppp  [wan_link0] LCP: SendTerminateReq #120 
    Nov 10 18:19:49  ppp  [wan_link0] LCP: LayerDown 
    Nov 10 18:19:49  ppp  [wan_link0] LCP: rec'd Terminate Ack #120 (Stopping) 
    Nov 10 18:19:49  ppp  [wan_link0] LCP: state change Stopping –> Stopped 
    Nov 10 18:19:49  ppp  [wan_link0] LCP: LayerFinish 
    Nov 10 18:19:49  ppp  [wan_link0] PPPoE: connection closed 
    Nov 10 18:19:49  ppp  [wan_link0] Link: DOWN event 
    Nov 10 18:19:49  ppp  [wan_link0] LCP: Down event 
    Nov 10 18:19:49  ppp  [wan_link0] LCP: state change Stopped –> Starting 
    Nov 10 18:19:49  ppp  [wan_link0] LCP: LayerStart 
    Nov 10 18:19:49  ppp  [wan_link0] Link: reconnection attempt 94 in 2 seconds 
    Nov 10 18:19:51  ppp  [wan_link0] Link: reconnection attempt 94 
    Nov 10 18:19:51  ppp  [wan_link0] PPPoE: Connecting to '' 
    Nov 10 18:19:51  ppp  PPPoE: rec'd ACNAME "VCTABC01AR07" 
    Nov 10 18:19:51  ppp  [wan_link0] PPPoE: connection successful 
    Nov 10 18:19:51  ppp  [wan_link0] Link: UP event 
    Nov 10 18:19:51  ppp  [wan_link0] LCP: Up event 
    Nov 10 18:19:51  ppp  [wan_link0] LCP: state change Starting –> Req-Sent 
    Nov 10 18:19:51  ppp  [wan_link0] LCP: SendConfigReq #121 
    Nov 10 18:19:51  ppp  [wan_link0] PROTOCOMP 
    Nov 10 18:19:51  ppp  [wan_link0] MRU 1492 
    Nov 10 18:19:51  ppp  [wan_link0] MAGICNUM 0xaca76c24 
    Nov 10 18:19:51  ppp  [wan_link0] MP MRRU 2048 
    Nov 10 18:19:51  ppp  [wan_link0] MP SHORTSEQ 
    Nov 10 18:19:51  ppp  [wan_link0] ENDPOINTDISC [802.1] 00 30 6e 5f 25 5c 
    Nov 10 18:19:51  ppp  [wan_link0] LCP: rec'd Configure Request #53 (Req-Sent) 
    Nov 10 18:19:51  ppp  [wan_link0] MRU 1460 
    Nov 10 18:19:51  ppp  [wan_link0] AUTHPROTO CHAP MD5 
    Nov 10 18:19:51  ppp  [wan_link0] MAGICNUM 0x0580dac7 
    Nov 10 18:19:51  ppp  [wan_link0] LCP: SendConfigAck #53 
    Nov 10 18:19:51  ppp  [wan_link0] MRU 1460 
    Nov 10 18:19:51  ppp  [wan_link0] AUTHPROTO CHAP MD5 
    Nov 10 18:19:51  ppp  [wan_link0] MAGICNUM 0x0580dac7 
    Nov 10 18:19:51  ppp  [wan_link0] LCP: state change Req-Sent –> Ack-Sent 
    Nov 10 18:19:51  ppp  [wan_link0] LCP: rec'd Configure Reject #121 (Ack-Sent) 
    Nov 10 18:19:51  ppp  [wan_link0] MP MRRU 2048 
    Nov 10 18:19:51  ppp  [wan_link0] MP SHORTSEQ 
    Nov 10 18:19:51  ppp  [wan_link0] ENDPOINTDISC [802.1] 00 30 6e 5f 25 5c 
    Nov 10 18:19:51  ppp  [wan_link0] LCP: SendConfigReq #122 
    Nov 10 18:19:51  ppp  [wan_link0] PROTOCOMP 
    Nov 10 18:19:51  ppp  [wan_link0] MRU 1492 
    Nov 10 18:19:51  ppp  [wan_link0] MAGICNUM 0xaca76c24 
    Nov 10 18:19:51  ppp  [wan_link0] LCP: rec'd Configure Ack #122 (Ack-Sent) 
    Nov 10 18:19:51  ppp  [wan_link0] PROTOCOMP 
    Nov 10 18:19:51  ppp  [wan_link0] MRU 1492 
    Nov 10 18:19:51  ppp  [wan_link0] MAGICNUM 0xaca76c24 
    Nov 10 18:19:51  ppp  [wan_link0] LCP: state change Ack-Sent –> Opened 
    Nov 10 18:19:51  ppp  [wan_link0] LCP: auth: peer wants CHAP, I want nothing 
    Nov 10 18:19:51  ppp  [wan_link0] LCP: LayerUp 
    Nov 10 18:19:51  ppp  [wan_link0] CHAP: rec'd CHALLENGE #196 len: 38 
    Nov 10 18:19:51  ppp  [wan_link0] Name: "VCTABC01AR07" 
    Nov 10 18:19:51  ppp  [wan_link0] CHAP: Using authname "mcrook250@teksavvy.com
    Nov 10 18:19:51  ppp  [wan_link0] CHAP: sending RESPONSE #196 len: 43 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: rec'd Configure Request #198 (Opened) 
    Nov 10 18:19:52  ppp  [wan_link0] MRU 1452 
    Nov 10 18:19:52  ppp  [wan_link0] AUTHPROTO PAP 
    Nov 10 18:19:52  ppp  [wan_link0] MAGICNUM 0x5aa98e38 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: LayerDown 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: SendConfigReq #123 
    Nov 10 18:19:52  ppp  [wan_link0] PROTOCOMP 
    Nov 10 18:19:52  ppp  [wan_link0] MRU 1492 
    Nov 10 18:19:52  ppp  [wan_link0] MAGICNUM 0xaca76c24 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: SendConfigAck #198 
    Nov 10 18:19:52  ppp  [wan_link0] MRU 1452 
    Nov 10 18:19:52  ppp  [wan_link0] AUTHPROTO PAP 
    Nov 10 18:19:52  ppp  [wan_link0] MAGICNUM 0x5aa98e38 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: state change Opened –> Ack-Sent 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: rec'd Configure Ack #123 (Ack-Sent) 
    Nov 10 18:19:52  ppp  [wan_link0] PROTOCOMP 
    Nov 10 18:19:52  ppp  [wan_link0] MRU 1492 
    Nov 10 18:19:52  ppp  [wan_link0] MAGICNUM 0xaca76c24 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: state change Ack-Sent –> Opened 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: auth: peer wants PAP, I want nothing 
    Nov 10 18:19:52  ppp  [wan_link0] PAP: using authname "mcrook250@teksavvy.com
    Nov 10 18:19:52  ppp  [wan_link0] PAP: sending REQUEST #1 len: 35 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: LayerUp 
    Nov 10 18:19:52  ppp  [wan_link0] PAP: rec'd ACK #1 len: 5 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: authorization successful 
    Nov 10 18:19:52  ppp  [wan_link0] Link: Matched action 'bundle "wan" ""' 
    Nov 10 18:19:52  ppp  [wan_link0] Can't join bundle wan without multilink negotiated. 
    Nov 10 18:19:52  ppp  [wan_link0] link did not validate in bundle 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: parameter negotiation failed 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: state change Opened –> Stopping 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: SendTerminateReq #124 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: LayerDown 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: rec'd Terminate Ack #124 (Stopping) 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: state change Stopping –> Stopped 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: LayerFinish 
    Nov 10 18:19:52  ppp  [wan_link0] PPPoE: connection closed 
    Nov 10 18:19:52  ppp  [wan_link0] Link: DOWN event 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: Down event 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: state change Stopped –> Starting 
    Nov 10 18:19:52  ppp  [wan_link0] LCP: LayerStart 
    Nov 10 18:19:52  ppp  [wan_link0] Link: reconnection attempt 95 in 3 seconds



  • I would really like to get MLPPP working. This seems to be an issue from 2.0 to 2.3+

    Is MLPPP broken or should I be posting in the Multi-WAN forum?



  • As I no longer use an MLPPP connection I can't be of much help other to say that I was using 2.3 snapshots early on without issue.