DNSBL DNS sever setting



  • Trying to set up pfblockerNG to block ads on network level. (result needed – replicate adblock plus on network level)

    Using DNS servers set up in general settings.

    Question which I cant find solution to is how/where to set the DNS server address when using DNSBL (unbound) as when DSN forwarder is disabled and resolver enabled DNS reverts to ISP provided DNS. Have looked but cant really see how  to set DNS server addresses (low information user here!)



  • Not sure I follow you entirely but this is where the DNSBL settings are in pfblockerng.

    http://imgur.com/a/WlYjL



  • Sorry to be unclear.

    Im trying to use  91.239.100.100 and 89.233.43.71 as the DNS server for my network. this is set in the PFsense general settings

    using DNS resolver and disabling DNS forwarder (which seems to be required to use DNSBL)  causes the DNS settings in the general setup to be ignored and the DNS servers from the ISP are applied.

    What I would like to know is where can I put my DNS server address to force their use?



  • I get you  :)

    OK have you checked under the 'General Setup' / 'DNS Server Settings' to see if the 'Allow DNS server list to be overridden by DHCP/PPP on WAN' option is enabled?

    If it is you might want to un-tick that option, define your DNS servers manually and test again.



  • Yep, tried it both ways plus placing DNS server addresses in the OPEN VPN override bit  (using openvpn as main interface so all traffic is thru the VPN)  and anywhere else I can find to put them but its ignored.

    Seems to be a problem with DNS resolver or my inability to find how to set up DNS on the system


Log in to reply