Install pfSense-pkg-nrpe-2.3.1_1.txz



  • Fetching pfSense-pkg-nrpe-2.3.1_1.txz: . done
    Fetching nrpe-ssl-2.15_6.txz: … done
    Fetching nagios-plugins-2.1.3,1.txz: .......... done
    Checking integrity... done (0 conflicting)
    [1/3] Installing nagios-plugins-2.1.3,1…
    [1/3] Extracting nagios-plugins-2.1.3,1: …....... done
    [2/3] Installing nrpe-ssl-2.15_6…
    ===> Creating groups.
    Creating group 'nagios' with gid '181'.
    ===> Creating users
    Creating user 'nagios' with uid '181'.
    /bin/sh: install: not found
    pkg: PRE-INSTALL script failed
    Failed


  • Rebel Alliance Developer Netgate

    Dropping a note here to match what I put on the bug report you opened:

    On a current snapshot, the package installs fine for me. Please update and try again.



  • I get the same error on a fresh install.  Also see this error when attempting to install Squid.

    2.4.0-BETA (amd64)
    built on Mon Nov 14 17:01:17 CST 2016
    FreeBSD 11.0-RELEASE-p3

    The system is on the latest version.


  • Rebel Alliance Developer Netgate

    What other packages do you have installed?



  • @jimp:

    What other packages do you have installed?

    When I first ran into this I was restoring my config file.  It tried to install Squid, Lightsquid, Squidguard, Cron, and OpenVPN Export.  The only packages that installed were Lightsquid, Cron, and OpenVPN Export.

    I then rebuilt clean and did not restore a config file.  I tried to install the nrpe package since I saw here that it had the same error and was possibly working.  The install failed.  I then tried to install squid and received the same error as the OP.


  • Rebel Alliance Developer Netgate

    I was able to reproduce it on a fresh install only, we've had that happen before though. Since the description on the nrpe ticket was not the actual problem, I started a new ticket and referenced the older 2.3.x ticket where this happened before: https://redmine.pfsense.org/issues/6934



  • It looks like this issue is fixed now.  I put a note on the bug report you filed.

    Thanks