PFblockerNG


  • Banned

    Cannot install PFblockerNG. Tried reinstalling PFsense. Using dev 2.4.0 11/11

    Here is the data output from the install

    Loading package instructions…

    Warning: require_once(xmlrpc.inc): failed to open stream: No such file or directory in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 30

    Call Stack:
        0.0002    231480  1. {main}() /etc/rc.packages:0
        0.0769  10836056  2. install_package_xml() /etc/rc.packages:74
        0.1594  12240664  3. require_once('/usr/local/pkg/pfblockerng/pfblockerng.inc') /etc/inc/pkg-utils.inc:716

    Fatal error: require_once(): Failed opening required 'xmlrpc.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear') in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 30

    Call Stack:
        0.0002    231480  1. {main}() /etc/rc.packages:0
        0.0769  10836056  2. install_package_xml() /etc/rc.packages:74
        0.1594  12240664  3. require_once('/usr/local/pkg/pfblockerng/pfblockerng.inc') /etc/inc/pkg-utils.inc:716

    pkg: POST-INSTALL script failed


  • Banned

    Found this in another post

    Run this in the shell
    fetch -o /etc/inc/xmlrpc.inc https://raw.githubusercontent.com/pfsense/pfsense/RELENG_2_3_2/src/etc/inc/xmlrpc.inc

    Worked!

    Hope I remember to delete the file when issue resolved with 2.4



  • If you remember can you remind me too.  8)


  • Banned

    I am actually using the shellcmd package now to run the fetch on bootup so the updates run ok.
    I am not sure I will know when PFblockerNG is fixed in 2.4. Haven't seen any bug reports for it so I am not sure it is even being worked on.



  • I thought I had it working, but on the first install although it said all OK there were no entries in my rules; removed it and added the early shell 'touch' and refetched xmlrpc.inc and re-installed and still nothing showing in the rules. Any ideas?