Keine IPV6 PD mehr nach Update 2.2.5 -> 2.3.2



  • Hallo zusammen,

    ich habe momentan folgenden Aufbau:

    WAN / Internet
                  :
                  : TCom VDSL
                  :
          .–---+-----.
          |  FB 7490 | 
          '-----+-----'
                  |
          WAN |
                  |
          .-----+-----.          DMZ          .------------.
          |  pfSense  +--------------------+  Server  |
          '-----+-----'                            '------------'
                |
          LAN |
                |
          .-----+-----.
          |  Clients  | 
          '-----+-----'

    Die Fritzbox bekommt das übliche /56 IPV6-Prefix und macht DHCPv6. Die pfSense bekommt an WAN Interface per DHCPv6 ein /60 Prefix von der FB und reicht das ganze an DMZ und LAN durch (Track Interface für DMZ/LAN). Das funktioniert auch soweit. Allerdings setze ich dabei die pfSense derzeit mit Version 2.2.5 ein. Nun habe ich testweise über die WebGUI auf Version 2.3.2 aktualisiert. Seitdem bekommt die pfSense offenbar kein Prefix mehr von der FB. Alle Einstellungen sind exakt so geblieben wie sie vorher waren und das Ganze lässt mich etwas ratlos zurück und ich bin zurück zur 2.2.5. Hat sich zwischen Version 2.2.5 und 2.3.2 irgendetwas in Sachen ICMP Handling geändert, sodass die pfSense jetzt vielleicht die RA der FB nicht mehr mitbekommt? Hier im Forum wurden ja schon einige ähnliche Probleme geschildert aber an der Konfiguration selbst kann es nun eigentlich nicht liegen, nur an den Änderungen zwischen den Versionen. Ich bin auch zu wenig BSDler als dass ich wüsste ob der Fehler vielleicht im Handling des OS vergraben ist.
    Hat jemand schon eine Ahnung wo da der (möglicherweise völlig triviale) Fehler sein könnte bevor ich nun die 2.3.2 noch einmal installiere und auf Suche in den Logs gehe?



  • Trail and Error hat zum Erfolg geführt.
    Problem war, dass in der WAN-Interface-Konfiguration "Request a IPv6 prefix/information through the IPv4 connectivity link" aktiviert war. Hat bisher allerdings problemlos funktioniert. Wie dem auch sei, jetzt bekommen alle Geräte wieder wir gehabt ihre v6-Adressen.