PfSense squidGuard Package Installation Issues



  • New user and first post - so please forgive any ignorance as I am new.

    I started to build white list domains for squidGuard and the system began to notify of crashes during the modifications. I thought I created the problem and uninstalled the squidGuard package, removed trace directories of squidGuard logs and configuration files then proceeded with the reinstall.

    The errors continue now during the installation and squidGuard is no longer listed within the toolbar under services even though pfSense indicates the package installed successfully.

    Below is information about the system and error.

    # uname -a
    FreeBSD $(NAME) 10.3-RELEASE-p9 FreeBSD 10.3-RELEASE-p9 #1 5fc1b19(RELENG_2_3_2)

    (Package available from GUI)
    squidGuard 1.14_4 High performance web proxy URL filter.

    (Package Installer Log/Status Messages)

    Installing pfSense-pkg-squidGuard…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    Checking integrity... done (0 conflicting)
    The following 3 package(s) will be affected (of 0 checked):

    New packages to be INSTALLED:
    pfSense-pkg-squidGuard: 1.14_4 [pfSense]
    squidGuard: 1.4_15 [pfSense]
    db5: 5.3.28_4 [pfSense]

    Number of packages to be installed: 3

    The process will require 15 MiB more space.
    [1/3] Installing db5-5.3.28_4…
    [1/3] Extracting db5-5.3.28_4: …....... done
    [2/3] Installing squidGuard-1.4_15…
    [2/3] Extracting squidGuard-1.4_15: …... done
    [3/3] Installing pfSense-pkg-squidGuard-1.14_4…
    [3/3] Extracting pfSense-pkg-squidGuard-1.14_4: …....... done
    Saving updated package information...
    done.
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    Custom commands...
    Executing custom_php_install_command()...done.
    Executing custom_php_resync_config_command()...done.
    Menu items... done.
    Services... done.
    Writing configuration...
    Fatal error: Allowed memory size of 104857600 bytes exhausted (tried to allocate 20661264 bytes) in /etc/inc/xmlparse.inc on line 317

    Call Stack:
        0.0002    230304  1. {main}() /etc/rc.packages:0
        0.0844  31276200  2. install_package_xml() /etc/rc.packages:106
      47.7930  33612096  3. write_config() /etc/inc/pkg-utils.inc:844
      48.8169  33616176  4. dump_xml_config() /etc/inc/config.lib.inc:565
      48.8170  33616176  5. dump_xml_config_raw() /etc/inc/xmlparse.inc:334
      48.8170  33616328  6. dump_xml_config_sub() /etc/inc/xmlparse.inc:353
      48.8217  33633248  7. dump_xml_config_sub() /etc/inc/xmlparse.inc:296

    PHP ERROR: Type: 1, File: /etc/inc/xmlparse.inc, Line: 317, Message: Allowed memory size of 104857600 bytes exhausted (tried to allocate 20661264 bytes)pkg: POST-INSTALL script failed

    (Default squidGuard installation information)

    Cleaning up cache… done.
    Success

    (Anonymous crash information)
    amd64
    10.3-RELEASE-p9
    FreeBSD 10.3-RELEASE-p9 #1 5fc1b19(RELENG_2_3_2): Tue Sep 27 12:26:06 CDT 2016    root@ce23-amd64-builder:/builder/pfsense-232/tmp/obj/builder/pfsense-232/tmp/FreeBSD-src/sys/pfSense

    Crash report details:

    PHP Errors:
    [15-Nov-2016 20:17:19 Pacific/Honolulu] PHP Fatal error:  Allowed memory size of 104857600 bytes exhausted (tried to allocate 20661264 bytes) in /etc/inc/xmlparse.inc on line 317
    [15-Nov-2016 20:17:19 Pacific/Honolulu] PHP Stack trace:
    [15-Nov-2016 20:17:19 Pacific/Honolulu] PHP  1. {main}() /etc/rc.packages:0
    [15-Nov-2016 20:17:19 Pacific/Honolulu] PHP  2. install_package_xml() /etc/rc.packages:106
    [15-Nov-2016 20:17:19 Pacific/Honolulu] PHP  3. write_config() /etc/inc/pkg-utils.inc:844
    [15-Nov-2016 20:17:19 Pacific/Honolulu] PHP  4. dump_xml_config() /etc/inc/config.lib.inc:565
    [15-Nov-2016 20:17:19 Pacific/Honolulu] PHP  5. dump_xml_config_raw() /etc/inc/xmlparse.inc:334
    [15-Nov-2016 20:17:19 Pacific/Honolulu] PHP  6. dump_xml_config_sub() /etc/inc/xmlparse.inc:353
    [15-Nov-2016 20:17:19 Pacific/Honolulu] PHP  7. dump_xml_config_sub() /etc/inc/xmlparse.inc:296

    I've highlighted the error message due to the fact that during the modification of the white list, I also received this error message - which is the same now while trying to reinstall the squidGuard package. I've attached my file for xmlparse.inc in the event that there is some form of corruption or typo others can note.

    All my investigation to find what this error is all about has me upset as now I cannot get squidGuard accessibility from the GUI as before. If I have to reinstall to fix the issue, so be it - but I would really like to learn what I may have done wrong or at least notify the community of a bug.
    xmlparse.txt



  • squidguard_configurator.inc must contains after require section [ln 53..]:

    /* Allow additional execution time 0 = no limit. */
    ini_set('max_execution_time', '3600');
    ini_set('max_input_time', '3600');

    ini_set('memory_limit', '50M');

    Locate file under /usr/local/pkg



  • @u3c307:

    squidguard_configurator.inc must contains after require section [ln 53..]:

    /* Allow additional execution time 0 = no limit. */
    ini_set('max_execution_time', '3600');
    ini_set('max_input_time', '3600');

    ini_set('memory_limit', '50M');

    Locate file under /usr/local/pkg

    Thank you for the reply and detailed direction on what to review for the future! Unfortunately, I do not have the ability to share whether or not these directions would have solved the problem because I rebuilt the router after being unable to find an answer online.

    Since I had a VERY brand new installation, I didn't lose much except for time in the rebuild. Even though I had to re-install the OS and get everything re-installed and configured, I'm happy for the experience and thus far the community cooperation and support.

    Thanks again - and I'll keep this saved in the event this happens again as I continue to refine my pfSense configuration.

    Additionally, for those that are curious - these are the default settings I found in the configuration file. Maybe I would need to bump up the amount to "200M" if this error comes up again?

    Allow additional execution time 0 = no limit

    –----------------------------------------------------------------------


    ini_set('max_execution_time', '3600');
    ini_set('max_input_time',    '3600');
    ini_set('memory_limit',      '100M');