Pfsense 2.3.2: не работает прозрачный режим прокси squid дl



  • Доброго времени суток!
    Помогите решить проблему:
    1. Установлена чистая система Pfsense 2.3.2-p1 (Status_dashboard.jpg)+squid (Installed_Packages.jpg)
    2. Подняты 2 интерфейса:
    WAN - 4G МТС
      IPv4 - 10.237.124.54,
      SUBNET MASK - 255.255.255.255,
      GW - 10.64.64.0,
      DNS - 213.87.0.1, 213,87.1.1,
    LAN -
      IPv4 - 10.3.129.1,
      SUBNET MASK- 255.255.255.0.
    3. Настроен squid в качестве transparent proxy (Squid_GS.jpg)
    4. Outbound Nat в режиме Automatic. Lan Firewall Rules (FW_LAN.jpg)
    5. На клиенте:
    LAN -
      IPv4 - 10.3.129.6,
      SUBNET MASK- 255.255.255.0,
      GW - 10.3.129.1.
    6. При явном указании прокси сервера 10.3.129.1 и порта 3128 в настройках браузера - сайты по протоколу http открываются.
    (лог FireWall - FW_LOG_PROXY.jpg).
    7. Если настройки прокси не прописывать - сайты по протоколу http не открываются.
    (лог FireWall - FW_LOG_INTERCEPT_PROXY.jpg). Пакеты уходят на squid и stop.
    Где собака зарыта? Заранее всем спасибо!














  • У меня точно такая же проблема после обновления на 2.3.2. Вы побороли её?
    Не работает сквид в прозрачном режиме. https работает, а http нет. Если прописывать порт и адрес прокси на компе, то всё ок. Так же инет работает без прокси у тех, кто не попадает под стандартное правило что из локальной сети всем разрешено. Естественно если его поставить выше всех, то всё работает, но это не выход.



  • Ох ты, а я думал я косяк, что у меня после установки на одном из PF новой версии прокси прозрачный не заработал.
    Подтверждаю, что на новой версии при настройке прокси по стандарту, http намертво отшибает, тобиш 80 порт.



  • Не поборол. Перешёл на версию 2.1.5. Все работает.



  • @Bansardo:

    Ох ты, а я думал я косяк, что у меня после установки на одном из PF новой версии прокси прозрачный не заработал.

    То есть у вас где-то на новой версии работает, а где-то нет?



  • Так же когда прописываешь прокси у пользователя. То всё нормально, кроме онлайн радио. Не работает не одно. В логах сквида пишет TCP_MISS_ABORTED/000 http://блаблабла
    Яндекс музыка, вк и тд работают. И опять же так стало после обновления. В acl разрешил все порты и толку нет. Кто-нибудь знает что делать?



  • С ошибкой  TCP_MISS_ABORTED/000  разобрался. Надо было в clamav поставить галку чтобы не проверял аудио и видео. Exclude Audio/Video Streams. This option disables antivirus scanning of streamed video and audio.
    Либо выключить антивирус совсем.



  • Есть ещё вопрос. Тк в версии 2.3.2 проблемы с прозрачным прокси, то пользователи ходят не через прозрачный) Так вот в сети есть сайты доступные только из локалки. Обращаются черз ип:порт. Они не доступны если прописывать прокси у пользователя. Так же перестаёт быть доступны веб морда pfsense и статистика lightsquid. Используется https, порт не стандартный. Просто не грузится страница. Если же прописать в исключения прокси у пользователя, то всё работает, но это не выход. Как быть?



  • Доброе.

    Либо выключить антивирус совсем.

    Верное решение. Толку от него нуль. Одни проблемы.



  • Надо бы добавить правило на 3128 порт. Взамен того, разрешающего весь LAN трафик. А вообще, у меня стоит squid3 - там и https еще, и правила на 3128-3129 порты настроены.




  • 2 NiXeon
    Доброе
    Тогда уж в Dest в fw на LAN не ***** , а LAN address или This firewall .



  • Так как решить проблему?
    тоже открываются сайты только https



  • Так и решайте. Откл. антивирус, к-ый идет вместе со сквидом, если он вкл. Создайте разр. правило на ЛАН, как описано ранее и поставьте его выше всех.



  • @werter:

    Так и решайте. Откл. антивирус, к-ый идет вместе со сквидом, если он вкл. Создайте разр. правило на ЛАН, как описано ранее и поставьте его выше всех.

    Антвирус был выключен изначально. Правило когда создаю на лан(как выше показано) то перестает работать даже по https.
    Эта проблема появляется только тогда когда установлен сквидгвард, если его удалить то пускает по хттп и хттпс.



  • По умолчанию в squidquard в Common ACL закрыт весь трафик, разрешил и всё заработало(http и htpps).
    Теперь вопрос если трафик был закрыт то как работал https?)



  • получается https трафик никак не контролируется?
    Сейчас заблокировал в сквидгварде сайт, по хттп блок а по хттпс доступен.



  • В итоге так и не решился вопрос по Transparent HTTP Proxy? http блокируется и всё!



  • При новой установки pfsense 2.3.3 и добавлении squid, так же не работает прозрачный прокси, идет блокировка http.



  • Такая же проблема  >:(