Can't get 2.4 to boot on EFI