OpenVPN conflicting with local network connection



  • I was recently in a hotel with WiFi configured as such:

    
    IP: 10.254.xx.xx
    Subnet Mask: 255.0.0.0
    Router: 10.128.128.128
    DNS: 10.128.128.128
    
    

    Make note of that aggressively large subnet.

    My network is 10.10.0.0/16. In particular I push 10.10.1.0 [255.255.255.0], 10.10.2.0 [255.255.255.0], 10.10.3.0 [255.255.255.0], 10.10.7.0 [255.255.255.0], 10.10.8.0 [255.255.255.0].

    When connecting over OpenVPN on iOS I was unable to connect to devices on my network over VPN presumably because of that subnet on the wifi network.  Is there a way to give OpenVPN routes priority?


  • Netgate

    No. Just stay away from anything in 10/8 for your local network. Pick something random for your LAN that isn't in 10/8, 192.168.0/24, 192.168.1/24 or 192.168.168/24.

    You can't fix idiocy like that but you can try to minimize the collisions.

    Two random examples:

    172.26.190.0/24
    192.168.188.0/24


  • Rebel Alliance Global Moderator

    "Make note of that aggressively large subnet."

    Really?  But your using a /16??

    "My network is 10.10.0.0/16"

    Isn't that the kettle calling the pot??  Why do people continue to use routing summary masks for their local networks???



  • I ran into the same issue a while back and solved it using the instructions from the user Efonne in this post:
    https://forum.pfsense.org/index.php?topic=43507.msg225465#msg225465