Acceder desde Internet por RDP a un equipo de mi LAN, error "CLOSED:SYN_SENT"



  • Buenas a todos, estoy tratando de acceder desde internet por RDP a un equipo que se encuentra dentro de mi LAN.
    Configure una placa para WAN y otra para LAN en pfsense

    Desde internet abro una RDP con la IP publica fija: y un puerto arbitrario: IP_PUB200.XX.XX.XX:10001

    Creo una regla en: Firewall –> NAT --> Port Forward
    Interface Protocol Source Address Source Ports Dest. Address Dest. Ports NAT IP NAT Ports                 Description
    WAN TCP/UDP *                 *                 200.XX.XX.XX 10001         IP_LAN 3389 (MS RDP) Server

    Me crea una Rules de la regla de arriba en Firewall --> Rules --> WAN

    Pero cuando quiero ingresar desde otra conexion de internet al RDP me dice que no lo puede encontrar y en el log me devuelve el siguiente error:

    WAN tcp 186.xx.xx.57:6437 -> IP_LAN:3389 (200.XX.XX.XX:10001) CLOSED:SYN_SENT 3 / 0 180 B / 0 B

    He verificado todo... puedo hacer el proceso inverso, salir desde mi LAN hacia internet, y el PFSENSE tiene funcionando correctamente WAN.
    Las reglas de NAT incluso las puse any to any y nada.

    Tengo el squid y squidguard configurado y funcionando con LDAP
    Gracias



  • Hola

    Segun tu regla, cambia "IP_LAN" Por la ip del equipo al cual te quieres conectar



  • Saludos mi estimado,

    en su caso no es problema de pfsense sino de como usted intenta establecer la conexion de escritorio remoto…

    si lo realiza de la manera comun y corriente que dispone windows para un usuario normal siempre tratara de realizarla por el puerto por defecto MS RDP (3389) lo que da como resultado el error que indica en su caso ya que usted ha establecido como puerto para conectarse el 10001.

    En su caso debe realizar la conexion via "mstsc" que no es mas que  un comando de consola windows mediante el cual puede especificar ip+puerto para la conexion a escritorio remoto...

    Quedo atento a su contacto



  • Buenos Días,

    Estimado

    Estuve asi por un tiempo y era algo tan sencillo como que debes como puerta de enlace la ip de tu Pfsense para que haga el redireccionamiento.

    Cualquier duda escribe si te funciono.



  • Buenas para todos, tengo el mismo problema, y he revisado todo, desde la maquina que tiene la conexión RDP como pfsense, yo estoy usando en los puertos el 3389 incluso probé con un FTP que tengo en la red y tampoco, eh leído varios manuales y visto algunos vídeo de como hacer el portforward a la ip de mi LAN pero no se conecta desde internet, lo gracioso de todo es que con la versión 2.2.X si funciona, pero con la nueva versión 2.3.X ya no se que hacer, gracias de antemano por sus comentarios.
    Aclaro que el proveedor de internet tiene un router en modo puente, el servidor PFSense se conecta por pppoe.
    ;)



  • @julinux:

    Buenas para todos, tengo el mismo problema, y he revisado todo, desde la maquina que tiene la conexión RDP como pfsense, yo estoy usando en los puertos el 3389 incluso probé con un FTP que tengo en la red y tampoco, eh leído varios manuales y visto algunos vídeo de como hacer el portforward a la ip de mi LAN pero no se conecta desde internet, lo gracioso de todo es que con la versión 2.2.X si funciona, pero con la nueva versión 2.3.X ya no se que hacer, gracias de antemano por sus comentarios.
    Aclaro que el proveedor de internet tiene un router en modo puente, el servidor PFSense se conecta por pppoe.
    ;)


    Estimado en tu caso es necesario que le digas al proveedor que el permita todo el trafico del puerto 3389 hacia la IP que el te proporciona y ya asi si puedes hacer el NAT tranquilamente.




  • Hola khrizthianxs, pero el dispositivo del proveedor esta en modo puente, con IP pública, eso es lo raro, gracias por su respuesta.  ;)



  • @😄:

    Hola

    Segun tu regla, cambia "IP_LAN" Por la ip del equipo al cual te quieres conectar

    hola gracias por responder…
    Tengo la regla creada con la ip a la que me quiero conectar, IP_LAN es meramente ilustrativo... en el Port Forward del NAT esta creado asi:

    Interface - Protocol - Source Address - Source Port - Dest.Address - Dest.Port - NAT IP - NAT Port - Descripcion
    WAN TCP * * 194.1.1.190 3389 (MS RDP) 200.5.116.74 10001 SERVER

    Y la WAN que se crea en la Regla es:

    Protocol - Source - Port - Destination - Port - Gateway - Queue - Schedule - Description
    IPv4 TCP * * 200.5.116.74 10001 * none   NAT SERVER



  • @khrizthianxs:

    Buenos Días,

    Estimado

    Estuve asi por un tiempo y era algo tan sencillo como que debes como puerta de enlace la ip de tu Pfsense para que haga el redireccionamiento.

    Cualquier duda escribe si te funciono.

    Hola, gracias por responder:
    debo poner la puerta de enlace en la maquina a la cual quiero acceder?



  • @amnarl:

    Saludos mi estimado,

    en su caso no es problema de pfsense sino de como usted intenta establecer la conexion de escritorio remoto…

    si lo realiza de la manera comun y corriente que dispone windows para un usuario normal siempre tratara de realizarla por el puerto por defecto MS RDP (3389) lo que da como resultado el error que indica en su caso ya que usted ha establecido como puerto para conectarse el 10001.

    En su caso debe realizar la conexion via "mstsc" que no es mas que  un comando de consola windows mediante el cual puede especificar ip+puerto para la conexion a escritorio remoto...

    Quedo atento a su contacto

    hola gracias por responder:
    Te comento que por el RDP de windows le especifico la IP:puerto, es decir… "IP_PUBLICA:10001"
    Asi ingresamos con el servidor anterior y no habia problema, ahora estamos migrando a PFSENSE y cree los PORTFORWARD correspondiente y me genero las REGLAS automaticamente, recien especifique como lo tengo configurado. gracias, espero respuesta



  • Hola oktuvre, pero te funciono asignando ip y puertos en source?, por que normalmente no se asigna ip, se deja en any o *, yo tengo el problema de portforwarding en pfsense la versión 2.3 y nada que me funciona, ah alguien le funciono el portforwarding en la versión 2.3?, gracias por sus respuestas.



  • Disculpen, alguìen ya probó el portforwarding en PFSENSE 2.3.1 o 2.3.2? a mi no me funciona como nomalmente funcionaba en la versión 2.2.x, gracias por sus respuestas.


  • Rebel Alliance

    @julinux

    Si, Funciona. (imágenes adjuntas de una prueba rápida)

    Creo que sería mejor que abras un nuevo tema respecto a tu problema  ;)