100% CPU usage



  • Hit an issue with my pfsense box yesterday - Internet kept dropping out, and I couldn't login to the GUI (although the login page came up, it wouldn't validate my creds).

    Finally managed to get logged in and the dashboard was showing 100% CPU usage (screenshot attached).

    Also managed to get the output form top, which showed this:

    Shell Output - top -aSH
    last pid: 87769;  load averages: 170.62, 170.23, 170.79  up 40+08:23:44    21:25:44
    547 processes: 180 running, 303 sleeping, 64 waiting

    Mem: 675M Active, 2582M Inact, 1137M Wired, 939M Buf, 11G Free
    Swap: 32G Total, 32G Free

    PID USERNAME PRI NICE  SIZE    RES STATE  C  TIME    WCPU COMMAND
    87012 root      73    0  224M 37280K RUN    1 189:31  5.76% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    7762 root      73    0  224M 37284K RUN    1 108:00  5.27% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    34304 root      73    0  224M 37268K RUN    5 318:10  5.18% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    36863 root      73    0  224M 37280K RUN    0 158:10  5.18% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    64162 root      73    0  224M 37284K RUN    6 121:34  5.18% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    63510 root      73    0  224M 37292K RUN    7  38:15  5.18% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    58174 root      73    0  224M 37296K RUN    7  26:40  5.18% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    21896 root      73    0  224M 37240K RUN    3 870:40  5.08% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    75984 root      73    0  224M 37256K RUN    0 495:54  5.08% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    30019 root      73    0  224M 37276K RUN    0 231:38  5.08% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    9242 root      73    0  224M 37256K RUN    5 511:35  4.98% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    61771 root      73    0  229M 39068K RUN    1 362:28  4.98% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron{php}
    52244 root      73    0  224M 37264K RUN    3 323:45  4.98% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    24209 root      73    0  224M 37292K CPU1    1  50:05  4.98% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    67805 root      73    0  228M 38924K RUN    2  23.3H  4.88% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron{php}
    64711 root      73    0  224M 37240K RUN    0 889:48  4.88% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    64465 root      73    0  224M 37248K RUN    7 669:02  4.88% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron
    15032 root      73    0  224M 37256K RUN    1 480:37  4.88% /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron

    Rebooted the box and all okay now. Had a look through the logs but couldn't see anything particularly relevant.

    Any ideas on config to check to prevent this from re-occurring ?

    Thanks.


  • Moderator