Strange website behavior after VPN



  • Hi guys,

    I had a pfsense install working 100%, upgraded to a new system and put in all the old settings by hand into the new system, now something's broken.

    Specifically, I am running PIA VPN and 99% of my traffic goes over the VPN.  I say 99% because I have firewall rules that route "*.mybankswebsite.com" out the default gateway, because I have major issues with my bank's website.

    Here's what's happening.

    When I run through the VPN, my bank's website hits me with extra authentication (text message to phone before I can log in).  When I test with my phone over my carrier's 4g network, or using my phone as a hotspot, there is no issue.

    With the firewall rules in place, if I specify my WAN interface (ie not VPN), it won't connect to the site at all.

    If I specify "default gateway" as the interface, it connects, but gives me the same behavior as though I was using the VPN.

    And now, my bank's website won't recognize my username and password from any computer on my network (works fine on cell phone over 4g).

    Now I know this is probably something going on with my bank, but since it works outside of my network, i'm wondering if something in pfsense is causing problems.

    The firewall rule to bypass the VPN interface does not appear to be working at all, however it is verbatim configured like the previous system was, which worked fine.

    Can anyone comment on these fancy new multi-layered authentication sites, why VPNs cause problems (rotating or blacklisted IPs?), and how to fix?

    Thanks.



  • Hi

    Old but hey!

    Seems your VPN Provider has been possibly marked as been known for Fraud or Fraudulent Attempts in the past or current, so they may ear mark it for "Further Authentication" to mitigate these attacks,.

    Failing that, it could be due to the way your VPN & your Machine handles the Certificate that the site provides.

    Hope this helped.