No WiFi



  • I am new to pfSense, so I expect some 'newbie' problems but this one seems fundamental.
    Firstly my system:-
    Jetway JBC320W
    Intel WiFi Link 1000 mini pcie

    pfSense appears to support the WiFi with the iwn driver and the interface is listed and its status available.
    The problem lies in the status reporting "No Carrier" and the interface has a big red cross against it.
    I have tried various configurations but no luck.

    Have I missed something very basic somewhere or is it indicating a faulty card … or something else?



  • Can you show a screenshot of your wireless interface config?



  • Attached as a png.

    ![WiFi setup.png](/public/imported_attachments/1/WiFi setup.png)
    ![WiFi setup.png_thumb](/public/imported_attachments/1/WiFi setup.png_thumb)



  • Some things is see:
    *You don't specify a standard.
    Set it to what you want it to be (a/an for 5Ghz, b/g/gn for 2.4Gbz)

    *You don't specify a channel.
    Set it to whatever frequency you want to use.

    *You have the interface configured as a client, not as an AP.
    Set the mode from "Infrastructure (BSS)" to "Access Point".

    Otherwise this seems sane.



  • Okay, I tried those suggestions.
    Standard : 802.11ng
    Channel : 11b/g/n - 6
    Mode : Access Point
    Save
    Apply Changes

    WiFi : Status : Down
    The Standard reverts to 'Auto' with no other selection available
    The Channel reverts to 'Auto' with no other selection available

    If I reset the Mode to 'Infrastructure (BSS)' the the Standard and Mode have options available again but the WiFi status returns to 'No Carrier'



  • What is the output in the syslog?

    Setting the mode to Infrastructure is really setting the device as a client.
    You want it as AP.

    Can you try to only set the mode to AP and apply.

    Did you make sure that the AP is really not working?
    –> see with a laptop or mobile phone if you can see the ssid.



  • @GruensFroeschli:

    –> see with a laptop or mobile phone if you can see the ssid.

    He can't, it's hidden  ;-)



  • Last I checked, the iwn driver only supported station and monitor modes and could not be used as an AP. (rant) Personally, I think having drivers for crap cards just confuses people. If someone really wants to run an Intel card in station mode, they can copy in the drivers and load it manually… (/rant)


  • Rebel Alliance Developer Netgate

    ^ that. Intel card drivers rarely if ever support running as an access point.

    Plenty of people use wireless for WANs or other links, not access points, so the drivers are still useful though. You just have to know going in what the hardware is capable of doing. There's a spreadsheet linked from the wiki that details hardware support for various cards.



  • Yes, I saw that the iwn driver did not support 'hostap' which is why I originally used infrastructure mode.
    The thinking being that it would tell me in the 'Status' if it was working whether I could connect to it or not.

    Just enabled SSID but nothing visible on my mobile (physically 1m away) so I guess the Status is reporting correctly.

    Do I assume I have a faulty card?

    I also have an AzureWave AW-NB159H but I read that the RTL8723 chip is not supported, so no hope there either.



  • You can't connect to it. It only works as a client (station mode)



  • Okay.
    But we seem to have drifted away from the real problem.

    Status : Dashboard - WiFi shows a red circle with a white cross in 'infrastructure mode' or a red down-arrow in 'access point mode'
    Status : Interfaces - WiFi (opt1, iwn0) has a Status  "no carrier" in 'infrastructure mode' or "down" in 'access point mode'

    Various configuration changes have had no effect so, is there a "Turn WiFi on" box I've missed in the configuration?  :-\

    @dotdash:

    You can't connect to it. It only works as a client (station mode)

    So how do I make use of the WiFi interface in this situation?


  • Rebel Alliance Developer Netgate

    You could use is as a wireless client only – meaning, it would connect to some other access point.

    It cannot, itself, host a wireless network as an access point.



  • Since I'm not going to be able to use this as an Access Point I see no purpose in trying to figure out how to get it to connect to an alternative Access Point on my network.

    So now to decide whether to find a mini PCIe wireless card which will work or go back to the Sophos UTM9 software (which also failed to use the wireless card).

    Thanks for the help  :)


  • Rebel Alliance Developer Netgate

    Most Atheros cards should work (pretty much any G, some N, probably not AC), and they're usually cheap and easy to find. I've got a couple AR9280-based cards and they're good.