OpenVPN



  • Bonjour,

    je viens de mettre en place en vpn avec openvpn, j'ai config mon serveur avec les certificats. J'ai suivi un tuto, j'ai config mon client openvpn sous windows tuto aussi.Jusque la pas de problème, je me connecte bien sur le vpn, seulement il m'attribue pas une bonne ip, du coup de ne peu pas voir mon réseau distant.
    Pourtant j'ai mis en place le serveur dhcp mais il ne le prend pas en compte apparemment.
    Comment puis je faire pour avoir une ip fixe sur mon client?

    merci



  • Bonjour,
    C'est curieux.
    Qu'as tu mis dans le champ "address pool" ?



  • dans le champ adresse pool j'ai mis ceci 10.26.23.0/24



  • est ce que tu arrives à pinger l'adresse 10.26.23.1 qui correspond à l'adresse du serveur OpenVPN, normalement il doit t'attribuer une adresse à partir de 10.26.23.6.
    si tu fais un ipconfig /all sur ton client windows, quelle est l'adresse de ton interface OpenVPN.
    Quel est le plan d'adressage de tes 2 réseaux:

    • Pfsense LAN et WAN
    • adressage IP de ton réseau distant.

    Vérifie que tu n'as pas coché l'option "Use static IPs" dans le serveur OpenVPN.
    Tiens nous au courant.



  • Je n'arrive pas a pinger l'adresse 10.26.23.1 pourtant mon client openvpn a pour adresse 10.26.23.1 masque 255.255.255.252? étrange je trouve  pas de passerelle.
    l'adressage du LAN est 10.26.23.0/24 le WAN est 83.206.139.xx/28
    celui du client est 192.168.1.0/24
    la casse use ip static n'est pas cocher



  • Je ne sais pas si tu as fait une coquille, mais je m'aperçois que tu as le même plan d'adressage pour la partie LAN de ton Pfsense et que tu utilises ce même plan d'adressage pour le réseau OpenVPN.
    Tous tes sous réseaux doivent être dans un plan d'adressage différent, modifie le champ address pool avec par ex 10.8.0.0/24 et dis nous ce qui se passe.
    Ton client OpenVPN devrait prendre l'adresse 10.8.0.6 et tu devrais pouvoir pinger ton interface LAN (10.26.23.xxx) ainsi que ton interface OpenVPN (10.8.0.1).

    Tiens nous au courant.



  • J'ai fais ce que tu m'as dit, j'obtiens bien 10.8.0.6 mais impossible de pinger, j'ai vu qu'il y avait aussi une histoire de push route faut t'il que j'en mette une?



  • Voici une capture d'ecran de ma config openvpn si sa peux aider




  • coche la case Dynamic IP, pour avoir un bail DHCP attribué par ton serveur OpenVPN.
    Ensuite dans la boite Local Network entre le sous réseau de ton LAN, si je ne trompe pas 10.26.23.0/24.
    Déconnecte toi, attention ne fait pas de reconnexion, je me suis aperçu que ça n'ajoute pas forcément les bonnes routes, reconnecte toi et enjoy le VPN à pas cher du tout…
    Essaye de pinger ton interface OpenVPN (10.8.0.1), ton interface LAN (10.26.23.1) et puis une autre machine sur le LAN.

    je rajoute "keepalive 10 120" (sans les côtes) pour la reconnexion, le DNS de mon réseau, NTP, le nom de domaine interne et puis le WINS.
    Ca devrait aller...



  • bon ça ne marche toujours pas je ne comprends pas, pourrais tu faire des captures d'ecran de ton install qui fonctionne et les ip de tes different reseau que je compare.

    la j'ai fais ce que tu ma dit, mais tjs pas de ping possible, les logs m'indique rien de particulier



  • pour le ping de ton réseau LAN, j'ai oublié qu'il fallait rajouter une règle dans le Firewall du type:

    Proto        Source                Port                Destination                      Port                            Gateway
    *            10.8.0.0/24          *                    LAN Subnet                    *                                *

    Concernant ma config réseau:
    LAN: 10.10.66.0/24
    WAN: compte PPPoE
    OpenVPN: 172.25.66.0/24

    Config du serveur openvpn_server.conf:
    #user nobody
    #group nobody
    daemon
    keepalive 10 60
    ping-timer-rem
    persist-tun
    persist-key
    dev tun
    proto udp
    cipher BF-CBC
    up /etc/rc.filter_configure
    down /etc/rc.filter_configure
    server 172.25.66.0 255.255.255.0
    client-config-dir /var/etc/openvpn_csc
    push "route 10.10.66.0 255.255.255.0"
    lport 1194
    push "dhcp-option DOMAIN toto.lan"
    push "dhcp-option DNS 10.10.66.1"
    push "dhcp-option WINS 10.10.66.1"
    push "dhcp-option NTP 10.10.66.254"
    ca /var/etc/openvpn_server0.ca
    cert /var/etc/openvpn_server0.cert
    key /var/etc/openvpn_server0.key
    dh /var/etc/openvpn_server0.dh
    comp-lzo
    persist-remote-ip
    float
    keepalive 10 120

    tu trouveras le fichier de config dans /var/etc
    en espérant que ca va t'aider



  • j'y suis enfin arrivé apres des jours de recherche je suis tombé sur le bon forum, grace a ton aide et a ce forum sa marche je te remercie pour ton aide précieuse.
    Pour info mon probleme venez de mon client windows vista et oui comme de par hazard.
    J'ai rajouté a la fin de la config de mon client les deux ligne suivante :
    route-method exe
    route-delay 2

    Et cela a fonctionné ensuite, voila si sa peux aider quelqu'un un jour.


Locked