Can´t install OpenVPN-client-Export



  • Hi Everyone,

    I am fairly new to pfSense. I´m using the "Version2.3.2_1" as a fresh installation, with currently no configuration.
    I´m currently facing an issue. I want to install the package
    "pfSense-pkg-openvpn-client-export".  And I am getting the error:

    New packages to be INSTALLED:
    pfSense-pkg-openvpn-client-export: 1.3.8 [pfSense]
    zip: 3.0_1 [pfSense]
    p7zip: 15.14_1 [pfSense]

    Number of packages to be installed: 3

    The process will require 6 MiB more space.
    1 MiB to be downloaded.
    pkg: https://pkg.pfsense.org/pfSense_v2_3_2_i386-pfSense_v2_3_2/All/pfSense-pkg-openvpn-client-export-1.3.8.txz: Not Found
    Failed

    While browsing to the link there is indeed no package that could be downloded. Did anyone see a similar issue and has a workaround?
    Any help is appriacted
    Cheers!


  • Banned

    Your pkg repo is completely outdated. Current version is 1.3.14.



  • i already tried to update the repository. either by using the option "Update from Console" or in shell using "pkg update". both times it shows:
    Updating repositories metadata…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    Your packages are up to date


  • Rebel Alliance Global Moderator

    Current version of export package is 1.3.15, just updated to it

    
    >>> Upgrading pfSense-pkg-openvpn-client-export... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    The following 1 package(s) will be affected (of 0 checked):
    
    Installed packages to be UPGRADED:
    	pfSense-pkg-openvpn-client-export: 1.3.14 -> 1.3.15 [pfSense]
    
    Number of packages to be upgraded: 1
    
    18 KiB to be downloaded.
    Fetching pfSense-pkg-openvpn-client-export-1.3.15.txz: .. done
    Checking integrity... done (0 conflicting)
    [1/1] Upgrading pfSense-pkg-openvpn-client-export from 1.3.14 to 1.3.15...
    [1/1] Extracting pfSense-pkg-openvpn-client-export-1.3.15: .......... done
    Removing openvpn-client-export components...
    Loading package instructions...
    Saving updated package information...
    overwrite!
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    Custom commands...
    Writing configuration... done.
    >>> Cleaning up cache... done.
    Success
    
    

  • Banned

    @stay159:

    i already tried to update the repository. either by using the option "Update from Console" or in shell using "pkg update". both times it shows:

    
    pkg update -f
    
    


  • yes, that did the trick. thanks a lot


  • Banned

    Good that it works. On that note - is your system clock sane? Cannot imagine why'd something say it's uptodate when it's ages behind.