Ciekawy technicznie problem z pfsense - Filezilla



  • Drodzy Panstwo,

    Po zmigrowaniu na PFSense w naszej sieci (WAN -PFSENSE - LAN) okazalo sie niemozliwym polaczenie z naszym serverem FTP w trybie ACTIVE.
    Problem wystepuje tylko gdy probuje sie polaczyc z komputera ktory jest w tej samej sieci lokalnej za ta sama zapora (PFSENSE) za pomoca zewnetrznego adresu (na potrzeby testu).

    Dla wyjasnienia:
    -polaczenie na wewnetrzny adres serwera ftp w sieci LAN dziala bez zarzutu
    -polaczenie na zewnetrzny (statyczny) adres IP (Swiatlowod) naszej sieci nie dziala zupelnie(oczywiscie port 21 jest przekierowany z WAN na adres serwera FTP)
    -polaczenie na nasz serwer z sieci zewnetrznej(na przyklad w domu) na zewnetrzny adres dziala takze bez problemu

    Port 21 zostal przekierowany na Firewall'u, polaczenia na dowolny inny serwer FTP nie stanowia problemu.
    Polaczenie przychodzace na nasz serwer z zewnatrz takze nie stanowi problemu.

    Jednakze polaczenie, jak pozwole sobie to nazwac w petli, czy gdy wychodzimy przez nasz Firewall, aby wrocic przez ten sam Firewall nie jest mozliwe do wykonania.

    Stacja robocza <–--> LAN <----> Firewall <----> Internet <----> Firewall (ten sam) <----> LAN (ten sam) <----> FileZilla Server.

    Mam nadzieje ze wyjasnilem ten dosc nietypowy przypadek.

    Bede wdzieczny za wszelkie sugestie czy da sie i jezeli tak to jak ten problem rozwiazac.

    Pozdrawiam
    Jakub Czyzewski



  • U mnie działa cały czas, chociaż faktycznie coś było na rzeczy po aktualizacji do PF2.3 Jak nie PF2.2.
    Wejdź do :    Firewall/NAT/Outbound i wybierz: Automatic outbound NAT rule generation. (pewnie już było aktywne)
    Albo to: System/Advanced/Firewall & NAT -> Enable NAT Reflection for 1:1 NAT -> włącz.

    Po włączeniu tego winno działać w sieci lokalnej wywołanie FTP po nazwie i adresie sieciowym.



  • Witam,
    Wielkie dzieki za pomoc.
    Pomogly ustawienia w System/Advanced/Firewall & NAT ->
    -NAT Reflection mode for port forwards  -> NAT +proxy
    -Enable NAT Reflection for 1:1 NAT-> wlaczone
    -Enable automatic outbound NAT for Reflection -> wlaczone

    Pozdrawiam ze slonecznej Marsylii,
    Jakub