Grrr, no wireless



  • Hi,

    New to pfSense. Have set up APU2 with the following:

    Connected WAN via static IP to exiting router - works OK - temp solution though.
    Set up PIA OpenVPN - works fine.
    Set up VPN bypass for ROKU - works fine.

    Can't get the wireless card to work. I have set  aut0 as the WLAN interface with:

    Enabled
    IP Config type - NONE
    Mode - Access Point
    WPA - Enabled
    SSID - pfsense
    WPA password and various other gubbins set.

    I have also created a bridge between LAN and WLAN.

    Wireless devices connect to the pfsense access point but complain about no Internet.

    I have tried lots of things including pass rules on WLAN to allow all traffic through. I have also tried giving WLAN a static IP on a different subnet and enabling DHCP on WLAN

    Help, BM

    EDIT:

    I changed:

    System > Advanced > System Tunables

    These must be changed from the default:

    net.link.bridge.pfil_member = 0

    net.link.bridge.pfil_bridge = 1

    Now I don't get no internet but using the browser just times out.

    EDIT2:

    I have gone back to the static IP config on WLAN. Looking at my Windows box on wifi I can see that DHCP is working but I am not getting a DNS server.

    EDIT 3:

    I realised that as I have Manual Outbound NAT rule generation I was missing mappings for WLAN but after adding these it still did not work. In windows I see the DNS server is 192.168.0.1 (WLAN subnet).



  • :-[ What a dick I am. I added the NAT mappings but got the source subnet wrong. All working now  ;D