Routing to remote wan ip subnet



  • Hey guys, so here's my q.

    I have my home network (10.13.10.0/24), and my work computer is on a subnet in the office as well (10.0.0.0/24)

    My PC at work (10.0.0.228) has hyper-v setup w/ a virtualized pfsense sitting between a virtual network (10.15.10.0/24) and my pc's sub-netted brethren.

    I have an openvpn connection open between my home pfsense (10.13.10.1) and my virtualized pfsense (10.15.10.1) at work.

    So it works really great.  I can access my work PC from my home network via it's virtual interface ip that lives behind the virtual pfsense (10.15.10.101) and any virtual machines I have inside the virtual 10.15.10.0/24 subnet can access any machine on my home network.

    What I'd really like to be able to do is route from pc's on my home network (10.13.10.0/24) to any random PC on my work's network (10.0.0.0/24).  I am unsure if I need to configure 10.15.10.1 as a router on my home pfsense, or somewhere else, or do something else all together.  I know this is a super kludgey setup, but I can't get my work to setup a openvpn host on their actual router so I'm stuck to doing just what I can do with my pc and hyper-v.  Let me know too if this can't be done at all because that is certainly a possibility.

    Also, I have configured in my "IPv4 Remote Networks" section of my home openvpn connection as 10.15.10.0/24,10.0.0.0/24

    Thanks much.



  • Are you able to access the works network from the virtualized one on your PC?
    If yes, the solution for your circumstance will be an outbound NAT rule on the works pfSense which translates the source address of vpn packets destined for the works network to the interface address of pfSense.

    To add such a rule go to Firewall > NAT > outbound. If it is set to automatic mode set hybrid and save this state. Then add a new rule, select the interface which is connected to the virtualized network, at source enter your home network, leave the other settings at their defaults and save it.



  • That worked perfectly.  Thanks so much!