Lightsquid em branco.



  • Bom Dia a Todos,

    Primeiramente desculpe se esse for um tópico duplicado

    Venho novamente solicitar ajuda de vocês. Tenho um Pfsense na versão 2.3.2-RELEASE-p1 e preciso gerar os relatórios do Lightsquid mas o mesmo só me apresenta uma tela em branco.

    Já desinstalei e instalei novamente, seguindo um procedimento que vi no fórum para remover alguns arquivos que ficam. Ja reconfigurei os logs do squid e nada.

    Apos alguns testes notei que quando clico para abrir a pagina do relatório se olho as linhas de programação(F12) da pagina ela nao faz solicitação nenhuma.

    Alguém pode me dar uma luz por favor.

    Caso precise de alguma informação adicional é so pedir.

    Só para constar já realizei diversos procedimentos em teste como por exemplo esse https://forum.pfsense.org/index.php?topic=103342.msg578402#msg578402  mas não tive sucesso. Em anexo telas do squid.










  • Em Report Template deixa selecionado: NovoSea
    e coloque para atualizar a cada duas horas.
    Você consegue acessar a plataforma dele via web?
    Você tentou dar um refresh Full? Ou apenas o refresh?
    Outra coisa, você liberou a porta que você colocou na sua configuração?
    Deixe a porta padrão 7445 e veja o que acontece.



  • @danilosv.03:

    Em Report Template deixa selecionado: NovoSea
    e coloque para atualizar a cada duas horas.
    Você consegue acessar a plataforma dele via web?
    Você tentou dar um refresh Full? Ou apenas o refresh?
    Outra coisa, você liberou a porta que você colocou na sua configuração?
    Deixe a porta padrão 7445 e veja o que acontece.

    Fiz z alteração da Template e do tempo > Ja tinha dado Refresh Full, mas re fiz, > O problema persisti
    A porta eu tinha acabado de alterar para teste voltei a default e continua a mesma coisa.

    Ele nao da erro algum quando clico no link "Open Ligthsquid" so me apresenta uma janela em branco.



  • @guilhermepaixao95:

    @danilosv.03:

    Em Report Template deixa selecionado: NovoSea
    e coloque para atualizar a cada duas horas.
    Você consegue acessar a plataforma dele via web?
    Você tentou dar um refresh Full? Ou apenas o refresh?
    Outra coisa, você liberou a porta que você colocou na sua configuração?
    Deixe a porta padrão 7445 e veja o que acontece.

    Fiz z alteração da Template e do tempo > Ja tinha dado Refresh Full, mas re fiz, > O problema persisti
    A porta eu tinha acabado de alterar para teste voltei a default e continua a mesma coisa.

    Ele nao da erro algum quando clico no link "Open Ligthsquid" so me apresenta uma janela em branco.

    Tu não consegue nem te logar? Nem a caixa de autenticação aparece? Tentou com outro navegador ?



  • @danilosv.03:

    @guilhermepaixao95:

    @danilosv.03:

    Em Report Template deixa selecionado: NovoSea
    e coloque para atualizar a cada duas horas.
    Você consegue acessar a plataforma dele via web?
    Você tentou dar um refresh Full? Ou apenas o refresh?
    Outra coisa, você liberou a porta que você colocou na sua configuração?
    Deixe a porta padrão 7445 e veja o que acontece.

    Fiz z alteração da Template e do tempo > Ja tinha dado Refresh Full, mas re fiz, > O problema persisti
    A porta eu tinha acabado de alterar para teste voltei a default e continua a mesma coisa.

    Ele nao da erro algum quando clico no link "Open Ligthsquid" so me apresenta uma janela em branco.

    Tu não consegue nem te logar? Nem a caixa de autenticação aparece? Tentou com outro navegador ?

    A caixa de autenticação aparece sim, desculpe. Ele autentica e depois fica tudo em branco




  • Testou em outro navegador?



  • Sim, mozila, chrome e IE. Existe alguma alternativa para o Ligthsquid? algum outro pacote?



  • @guilhermepaixao95:

    Sim, mozila, chrome e IE. Existe alguma alternativa para o Ligthsquid? algum outro pacote?

    Tu tem regra de portas ai? Como é o teu proxy: squi e squiguard (se utilizar).
    me fale um pouco do seu cenário e vai mandando print detalhado das tuas configurações. Acredito que isto está sendo erro de configuração. Algum fragmento que estamos deixando passar.



  • @danilosv.03:

    @guilhermepaixao95:

    Sim, mozila, chrome e IE. Existe alguma alternativa para o Ligthsquid? algum outro pacote?

    Tu tem regra de portas ai? Como é o teu proxy: squi e squiguard (se utilizar).
    me fale um pouco do seu cenário e vai mandando print detalhado das tuas configurações. Acredito que isto está sendo erro de configuração. Algum fragmento que estamos deixando passar.

    Entao assim o pfsense tem regras no firewall, varias vpns utiliza o squid e o squidgard.

    Squid gera relatórios, a aba realtime esta identificando o trafego. Os aquivos de log do squid esta com informações. O log de acesso do squid tem 2GB de informação.
















  • Desabilita log rotation no squidguard
    E em blacklisst options coloca o IP do teu pfsense o mesmo que tu acessa via browser
    A porta de acesso ta errada do lightsquid.
    Não é Lan Address é LAN net. Veja que nem passa trafego quando você tenta acessar o light, por isso o erro da página em branco. Mude a ou suorce e me diz.



  • :'( :'( :'( :'( :'(

    Mesma coisa, refiz a regra, coloquei o ip no squidguard e a porta esta a Defaul. Por habito apos qualquer configuração "Apply" no squidguard e restartei os 3 pacotes










  • Faça o seguinte. Coloque o seu IP Bypass Proxy for These Source IPs no squid e teste mais uma vez.



  • @danilosv.03:

    Faça o seguinte. Coloque o seu IP Bypass Proxy for These Source IPs no squid e teste mais uma vez.

    Bom Dia,

    Coloquei e sem mudança alguma… Tentei tb acesso por um link externo para ver se não era algum bloqueio mas deu a mesma coisa... é como se ele "chamasse" a interface do ligthsquid.



  • To estranhando porque a instalação e configuração do light é super simples. Quando você vai em Rules você ver o trafego passando? Tire print do seu local cache no squid.



  • Amigo acabei de perceber uma coisa a tela sqstat tb nao esta listando as maquinas rodando no momento. A empresa esta a 1000 e o acesso nao esta sendo capturado por ela.




  • Cara uma coisa que deixei passar despercebida. Vá nas configurações do lightsquid e marca a opção: Lighsquid Web SSL ela está desmarcada e mantém o resto das configurações.



  • @danilosv.03:

    To estranhando porque a instalação e configuração do light é super simples. Quando você vai em Rules você ver o trafego passando? Tire print do seu local cache no squid.

    Criei uma regra liberando a porta 3128 so para monitorar o trafego, na mesma hora ela ja gerou o log. Segue imagens do log do squid








  • @danilosv.03:

    Cara uma coisa que deixei passar despercebida. Vá nas configurações do lightsquid e marca a opção: Lighsquid Web SSL ela está desmarcada e mantém o resto das configurações.

    Lei esse meu post. E veja como irá funcionar.



  • @danilosv.03:

    Cara uma coisa que deixei passar despercebida. Vá nas configurações do lightsquid e marca a opção: Lighsquid Web SSL ela está desmarcada e mantém o resto das configurações.

    Essa opção estava marcada eu desmarquei em teste. Marquei novamente salvei, dei refrsh full e mesma coisa tela branca..



  • @guilhermepaixao95:

    @danilosv.03:

    Cara uma coisa que deixei passar despercebida. Vá nas configurações do lightsquid e marca a opção: Lighsquid Web SSL ela está desmarcada e mantém o resto das configurações.

    Essa opção estava marcada eu desmarquei em teste. Marquei novamente salvei, dei refrsh full e mesma coisa tela branca..

    Me chama no skype.



  • cara estou com esse mesmo problema!! já  fiz de tudo conforme post informam mas sem sucesso o ultimo foi criar um link do \var\squid\logs para \var\squid\log  sem sucesso.. já instalei reinstalei removendo os diretórios  rezei fiz macumba e nada!!



  • Como está as configurações do seu pfsense e como é o seu cenário hoje?

    antes de qualquer coisa o próprio lightsquid ele explica como você faz para ativar ele:

    1 / Habilitar 'Acesso Logging' no pacote Squid! É altamente recomendável deixar o 'Log Store Directory' no pacote Squid no valor padrão '/ var / squid / logs'.
    
    2 / SOMENTE se o Squid não estiver configurado como proxy transparente:
    - Configurar Squid - Geral - Proxy Interface (s) para incluir 'loopback' interface (além de quaisquer outras interfaces que você deseja Squid para ligar).
    3 / Configure 'Configurações do Modelo de Relatório' e 'Configurações de Relatório e Agendador' abaixo e Salve quando terminar.
    
    4 / Use os botões Refresh na seção 'Atualização manual' abaixo para criar relatórios LightSquid iniciais; Caso contrário, você receberá uma página de diagnóstico de erro.
    - "Refresh now" (re) analisará as entradas de hoje apenas no acesso atual do Squid.
    - "Refresh full" irá (re) analisar todas as entradas em todos os logs de acesso do Squid, incluindo os girados. Nota: Isso pode levar muito tempo para terminar!
    


  • cara então eu acho que tem uma M ai eu fui refazer as configurações na pagina do Squid proxy reports e ao salvar ele me informa que eu preciso informa a interface de loopback e foi o que eu fiz marquei a Lan ea loopback  salvei  e quando retornei a pagina do Squid proxy reporte e tento salvar as alterações ele me diz que o diabinho da loopback deve ser selecionada…

    deve ser alguma M ai ... não esta salvando ou ele não esta enxergando que a loopback foi marcada... eu acho ne



  • @fgsou:

    cara então eu acho que tem uma M ai eu fui refazer as configurações na pagina do Squid proxy reports e ao salvar ele me informa que eu preciso informa a interface de loopback e foi o que eu fiz marquei a Lan ea loopback  salvei  e quando retornei a pagina do Squid proxy reporte e tento salvar as alterações ele me diz que o diabinho da loopback deve ser selecionada…

    deve ser alguma M ai ... não esta salvando ou ele não esta enxergando que a loopback foi marcada... eu acho ne

    Pra funcionar você tem que configurar o seu squid como proxy transparente, instalar uma CA pra ele e depois configurar o lightsquid, não tem erro.



  • Pior que esta funcionando mas já fazia um bom tempo que eu não usava ele … mas vou gastar um tempo nele pra ver


Log in to reply