Monitoring stops after reboot, now SyntaxError: JSON.parse: unexpected chara



  • Hi!

    Got an odd one here which I would like to figure out why it's happening. The monitoring stops, flat lines, after a reboot. Can't get it going again without doing a "Reset Graphing Data".

    Unsure which info I can provide to help out here.

    I have no RRD or monitoring events in the systemlog after reboot.

    Running on latest stable.

    
    [2.3.2-RELEASE][root@not.at.home]/var/db/rrd: ls -la
    total 8068
    drwxr-xr-x   2 nobody  wheel    1024 Dec 24 03:14 .
    drwxr-xr-x  19 root    wheel    1024 Jan  4 19:23 ..
    -rw-r--r--   1 nobody  wheel  147848 Jan 19 19:02 WAN_DHCP-quality.rrd
    -rw-r--r--   1 nobody  wheel  393168 Jan 19 19:02 ipsec-packets.rrd
    -rw-r--r--   1 nobody  wheel  393168 Jan 19 19:02 ipsec-traffic.rrd
    -rw-r--r--   1 nobody  wheel  441864 Jan 19 19:02 lan-dhcpd.rrd
    -rw-r--r--   1 nobody  wheel  393168 Jan 19 19:02 lan-packets.rrd
    -rw-r--r--   1 nobody  wheel  393168 Jan 19 19:02 lan-traffic.rrd
    -rw-r--r--   1 nobody  wheel  882048 Jan 19 19:02 ntpd.rrd
    -rw-r--r--   1 nobody  wheel  393168 Jan 19 19:02 opt1-packets.rrd
    -rw-r--r--   1 nobody  wheel  393168 Jan 19 19:02 opt1-traffic.rrd
    -rw-r--r--   1 nobody  wheel  393168 Jan 19 19:02 opt2-packets.rrd
    -rw-r--r--   1 nobody  wheel  393168 Jan 19 19:02 opt2-traffic.rrd
    -rw-r--r--   1 nobody  wheel  393168 Jan 19 19:02 ovpns2-packets.rrd
    -rw-r--r--   1 nobody  wheel  393168 Jan 19 19:02 ovpns2-traffic.rrd
    -rw-r--r--   1 nobody  wheel   49720 Jan 19 19:02 ovpns2-vpnusers.rrd
    -rw-r--r--   1 nobody  wheel  588592 Jan 19 19:02 system-mbuf.rrd
    -rw-r--r--   1 nobody  wheel  735320 Jan 19 19:02 system-memory.rrd
    -rw-r--r--   1 nobody  wheel  245976 Jan 19 19:02 system-processor.rrd
    -rw-r--r--   1 nobody  wheel  245976 Jan 19 19:02 system-states.rrd
    -rw-r--r--   1 root    wheel   10101 Jan 19 19:02 updaterrd.sh
    -rw-r--r--   1 nobody  wheel  393168 Jan 19 19:02 wan-packets.rrd
    -rw-r--r--   1 nobody  wheel  393168 Jan 19 19:02 wan-traffic.rrd
    [2.3.2-RELEASE][root@not.at.home]/var/db/rrd: ps
      PID TT  STAT    TIME COMMAND
    54668 v0- SN   0:04.32 /bin/sh /var/db/rrd/updaterrd.sh
    71734 v0  Is   0:00.01 login [pam] (login)
    72147 v0  I    0:00.00 -sh (sh)
    72402 v0  I+   0:00.00 /bin/sh /etc/rc.initial
    37789  0  R+   0:00.00 ps
    93040  0  Is   0:00.00 -sh (sh)
    93368  0  I    0:00.01 /bin/sh /etc/rc.initial
    94784  0  S    0:00.05 /bin/tcsh
    
    

    And a Picture of how it looks after a reboot i attached.

    ![stop monitor.png](/public/imported_attachments/1/stop monitor.png)
    ![stop monitor.png_thumb](/public/imported_attachments/1/stop monitor.png_thumb)



  • Hi to my self and hopefully someone who can give a lead on to what the trouble might be.

    Tried updating to latest 2.3.3,
    Now I get, this from the monitoring page.

    "Error: SyntaxError: JSON.parse: unexpected character at line 2 column 1 of the JSON data"

    2.3.3-DEVELOPMENT (amd64)
    built on Thu Jan 05 06:45:19 CST 2017
    FreeBSD 10.3-RELEASE-p12




  • Hi "I got my own thread!"  :)

    I found the cause but not sure if its solvable.

    My pfsense is a guest in a Windows 2012 R2 Hyper-V. A reboot of the pfsense made the clock take a jump, backwards.  ::)

    Running the update script manually show this:
    ERROR: /var/db/rrd/ovpns2-traffic.rrd: illegal attempt to update using time 1483895952 when last update time is 1484149652 (minimum one second step)
    1484149652s-1483895952s=253700s, ~1h10m …

    I had the guest-service for the guest machine turned off in Hyper-V because I wanted pfsense to manage the time through NTP by it self.

    I'll proceed with some trial and error here to see which combination of time-sync that's working in my setup.


Log in to reply