Sysctl boot message: empty numeric value



  • I think it came after adding some system tunables in the GUI and then removing them after further testing. Now I receive error message during boot, how can i diagnose what is wrong?



  • Rebel Alliance Developer Netgate

    Look in your config.xml at the section for tunables, post that section here. There wouldn't be anything private/identifiable in it.



  • Is it sysctl section?

    
     <sysctl><tunable>vfs.read_max</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.ip.portrange.first</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.blackhole</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.udp.blackhole</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.ip.random_id</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.drop_synfin</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.ip.redirect</tunable>
    			<value>default</value> 
    		 <tunable>net.inet6.ip6.redirect</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.syncookies</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.recvspace</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.sendspace</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.delayed_ack</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.udp.maxdgram</tunable>
    			<value>default</value> 
    		 <tunable>net.link.bridge.pfil_onlyip</tunable>
    			<value>default</value> 
    		 <tunable>net.link.bridge.pfil_member</tunable>
    			<value>default</value> 
    		 <tunable>net.link.bridge.pfil_bridge</tunable>
    			<value>default</value> 
    		 <tunable>net.link.tap.user_open</tunable>
    			<value>default</value> 
    		 <tunable>kern.rndtest.verbose</tunable>
    			<value>default</value> 
    		 <tunable>kern.randompid</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.ip.intr_queue_maxlen</tunable>
    			<value>default</value> 
    		 <tunable>hw.syscons.kbd_reboot</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.inflight.enable</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.log_debug</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.icmp.icmplim</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.tso</tunable>
    			<value>default</value> 
    		 <tunable>kern.ipc.maxsockbuf</tunable>
    			<value>209715200</value></sysctl> 
    
    


  • I have sanitized this section leaving only the last item, removing all other and it solved the problem.
    Looks like those  items with "default" value are inherited from old versions of pfSense and some of them do not processed correctly when value is just "default", but not numeric ?



  • IIRC the whole sysctl default settings are built-in in now, at least in 2.3x. So you should be safe to delete everything "default". I don't have any sysctl in my config at all. Don't know if the update process removed them or if it was me :)



  • No, if you are restoring from older version to new or upgrading, then this section is just moved, but it would be good if pfsense cleans unmodified/unused values and leaves or merges only user modified entries.


Log in to reply