Problem setting up an AP



  • Hi,

    I'm using a very small PC as a gateway at home to share internet among all the PCs in the house. But I thought that I'd add in a wireless card and I wouldn't have to have another AP. So I inserted a Ralink wifi card into the PC. PFS Actually detected the card fine and I was able to configure it in the config menu.
    But here's where the problems started. If I only set up an open wlan I could connect via any device. But the moment I setup any kind of protection (WEP or WPA) I kept getting gateway errors. But the device was registered in the dhcp lease table.

    Anyone have any idea what would be the problem or how I could get it working?
    I thought that Ralink chipsets were supported so I don't know if I did something wrong or is there something to watch out for when configuring wifi?

    Thanks for the help.

    Bye



  • Ok a little update. No matter how I set things up I always get a no gateway replay on the client even if the client shows up in the dhcp leas log. I've tried setting up the wifi as a separate interface or bridged with LAN. Either way it doesn't work.
    I followed the instructions of a tutorial I found on this forum that should work but something is giving me problems.

    Bye



  • Can anyone help me. Because I'm still getting the same error and I still can't connect with any device.

    Thanks and bye



  • If would help if you gave us a bit more information to work with:

    What version of pfSense?

    What client?

    What are you trying to do when you get the "no gateway" reply?

    Has the client accepted the DHCP assigned address?

    What tutorial were you following?

    You don't mention setting protection in a client. Is that significant? (Of course it will have to compatible with the protection you have set in the pfSense box.)



  • I have PFS 1.2-RC4.
    I have tried with Ubuntu, WinXP, Vista and Nokia n95. There is currently no protection on the wireless lan and I have added the appropriate rule to let traffic out from this card. Now if I try to access the wlan via any of the mentioned systems it works but the moment I turn on any kind of encryption wired things start to happen. With the Ubuntu system it actually shows up in the DHCP lease but after a few moments it starts acquiring the IP again (The system works with WPA & WPA2 fine else ware). With the WinXP system it seems to work now that I have set it to WPA. But after a few moments no pages open anymore unless you reconnect and then the same pattern a few moment and then again. Same with Vista but the Nokia n95 just gives "no gateway replay" message. If I try setting to WEP it doesn't work anywhere. Only the not protected works everywhere.

    Blows my mind.

    Any ideas?

    Thanks and bye



  • What device name does the ralink card have (ral, ural, rum)?

    Are you getting anything about the ralink card logged on the console or in the system logs?

    I have a rum (USB wireless adapter) I could try out tomorrow night when I have a laptop with a wireless NIC.



  • The ralink card shows up as ral0 it's a PCI card.
    Anyway anything I try works only if I disable any kind of protection. With it no go.
    Nothing is outputted on the console as for syslog I'm not actually sure what I should be looking for.
    But clients show in the dhcp lease log even if the encryption is enabled.

    Thanks.
    Bye


Locked