Rutas estáticas sin WAN



  • Hola,

    Tengo un router cisco que uso como mi puerta de enlace predeterminada en mi LAN, se usa para enrutar trafico dependiendo de si es tráfico para otro site, para navegar por internet o voz, asi que tiene rutas como:

    ip route 192.168.3.0 255.255.255.0 192.168.1.3
    ip route 192.168.10.0 255.255.255.0 192.168.1.2
    ip route 192.168.11.0 255.255.255.0 192.168.1.200

    He añadido las rutas y los gateways en un nuevo router pfsense que he configurado pero pfsense me obliga a ponerle un interface WAN (mi router antiguo no tenia), sin embargo los otros routers estan en la misma subnet que el mio 192.168.1.X.

    He encontrado este post donde se hablaba del tema:

    https://forum.pfsense.org/index.php?topic=53901.0

    Y he probado lo siguiente:

    He probado a configurar las rutas estáticas con la interface LAN y deshabilitar la interface WAN, pero entonces no funciona.
    He probado a configurar las rutas estáticas con la interface LAN y dejar la interface WAN habilitada pero sin IP asignada con el mismo resultado.
    He probado a configurar la interface WAN por DHCP, pero entonces me enruta el tráfico a través de la puerta de enlace definida en el DHCP pese a que es las rutas estáticas esté definida como interface la LAN.
    Y por último he probado a configurar WAN por DHCP y entonces deshabilitar el gateway que genera cuando lo configuras por DHCP, pero aún así sigue enrutando el tráfico por la puerta de enlace del DHCP.teway even the static routes are attached to LAN interface.

    Alguna idea?



  • Buenas Remiel

    Has creado una puerta de enlace para la LAN? Entiendo que sí pero no me queda claro del todo.

    Por defecto el sistema no la crea. Si tu gateway es un equipo que está en una red accesible a través de la LAN tienes que crear primero el gateway LAN (Sistema .> Routing -> Gateways) para poder definir las rutas de las que hablas.



  • Saludos mi estimado,

    recuerda que pfsense se comporta como router y por ello te exige la configuracion de una interfaces WAN mas no creo que esto sea problema para lo que deseas realizar….

    He configurado gateways adicionales en lan o dmz y no ha habido problema con ello...ç

    si tomaras en cuenta las recomendaciones al postear creo que desde hace un buen tiempo hubieses encontrado salida al problema....

    Quedo atento



  • Hola,

    Gracias a los 2 por contestar. Sí mikee, había creado varios gateways (son obligatorios para crear las rutas estáticas). Por otro lado, amnarl si con las recomendaciones al postear te refieres a buscar el problema para no crear posts repetidos si lo hice y no he encontrado nada al respecto.

    Sin embargo buscando por mi cuenta he conseguido que funcione configurando en la interface LAN un upstream router con la ip del router de navegación por internet y deshabilitando la interface WAN (Si,amnarl, si se puede). Ahora bien, funciona todo correctamente excepto que cuando conecto por RDS a un servidor en otro site de vez en cuando la pantalla se congela por 2 o 3 segundos. También tengo una aplicación con instalación local que se conecta a un BD en otro site y sufre un comportamiento similar. La navegación va bien, las llamadas de voz también, y si hago pings a los servidores afectados parece estable, no hay cortes y los tiempos de respuesta son similares. Alguna idea?



  • Buenas Remiel. Disculpa el retraso en contestar pero no tenía activada la notificación en este thread y no me enteré de las respuestas.

    Has conseguido resolver todos los problemas (los indicados en el último mensaje me refiero)? Dado el tiempo transcurrido es posible que sí pero por si acaso mejor preguntar.


Log in to reply