Squid/clamav not starting



  • Just installed squid and running the cache proxy on defaults.  and enabled the clamav, but going into services/status clamd is showing off.

    following another thread by which I type in "freshclam" in command prompt the following messages appear and then I try to start the clamd service, it still doesn't start.  help please. thanks

    running pfsense 2.3.2 nanobsd

    ClamAV update process started at Mon Jan  9 14:15:01 2017
    getfile: Can't write 1440 bytes to /var/db/clamav/clamav-0796be9037dbc97f1d26191b52bb7401.tmp/clamav-785b550b0008e86527f167a5244af7c7.tmp
    WARNING: Can't download main.cvd from db.europe.clamav.net

    c-icap ICAP Inteface for Squid and ClamAV integration Running
    clamd ClamAV Antivirus                                         Stopped
    dhcpd DHCP Service                                                 Running    
    dpinger Gateway Monitoring Daemon                         Running    
    ntpd         NTP clock sync                                                 Running    
    squid         Squid Proxy Server Service                         Running    
    unbound DNS Resolver                                                 Running


  • Banned

    If your AV definitions cannot be downloaded/saved, then it won't ever run. (On that note, you'll have a very miserable experience with this unless you upgrade to 2.3.3 snapshots, because otherwise the AV defs will be gone after every reboot.)



  • hmm, is the mirror down or something?  I used a EU mirror tried GB mirror and it is the same result.

    is the issue of saving AV def inherently linked to the fact that I am running nanobsd?

    would it be better if i migrate the system to HDD?


  • Banned

    In general, yes, you would be a whole lot better off dropping the nanobsd altogether.  And no, I don't think it's a mirror down.

    
    Can't write 1440 bytes to /var/db/clamav...
    
    

    suggests the ramdisk is full or whatever other fluke related to nanobsd is happening.


Log in to reply