Squid Logging Extern



  • Good Morning,

    I'm struggling with my Squid Proxy on pfSense.
    The problem is, that I need to save the access logs on a NAS for redundancy.
    I've added the official FREEBSD repository in my pfsense and tried mounting a folder from my NAS as local folder on pfsense with curlftpfs.
    I got the error:
    "curlftpfs" fuse: failed to open fuse device: No such file or directory
    It looked like the packages were not fully installed.
    I tried mounting with smb then buth both ways didn't work for me.
    Has anyone got external logging to work ?
    I also tried writing the access logs into the syslog server with this instruction:
    https://forum.pfsense.org/index.php?topic=49351.0

    The problem is, that if I add
    "access_log syslog:local5.info squid" to the configuration, the squid stops working.

    Thanks in advance !


  • Banned

    Last time I checked logging to remote syslog server, Squid committed a suicide when the remote logging failed. Since then, I've not investigated adding any such option to the package, since that's been just incredibly lame and useless.



  • @doktornotor:

    Last time I checked logging to remote syslog server, Squid committed a suicide when the remote logging failed. Since then, I've not investigated adding any such option to the package, since that's been just incredibly lame and useless.

    Thank you for your answer !
    That sounds bad :/
    I have installed pfsense on an old pc and I need the logs on my NAS, which is in the same subnet.
    Any idea how to mount a ftp folder as local folder on my pfsense ?
    This would also solve my problem.


  • Banned

    This is equally bad. If you reboot the NAS, it would kill Squid. Squid not being able to log => the service will stop. Documented behavior, last checked with 3.3.x there was no option to change this. Might have another look if there's a toggle to avoid this in 3.5.x or dig the docs yourself.



  • @doktornotor:

    This is equally bad. If you reboot the NAS, it would kill Squid. Squid not being able to log => the service will stop. Documented behavior, last checked with 3.3.x there was no option to change this. Might have another look if there's a toggle to avoid this in 3.5.x or dig the docs yourself.

    wow, this sounds very bad :/
    My instructor wants a redudance logging solution ..
    So it is not possible currently with the pfsense ?
    NAS is running 24/7 with an Uninterruptible Power Supply.
    So remote logging should be available always -> Squid not suiciding :)

    We are trying to use it as a public guest hotspot.
    Captive Portal and APs are working fine, last problem is the logging.
    Do you know any other solutions which I could use instead of pfsense with the same functions ?

    Thank you !


  • Banned

    If you want the logs elsewhere, do it the other way round – like, SCP/SFTP the logs from pfSense to your NAS via cron.


Log in to reply