2.4 with ZFS-root won't boot..



  • I had 2.3.2 loaded, and figured as 2.4 was close and had ZFS I would give it a roll as well.  So I proceeded to slick my 2.3 system, and loaded up 2.4 beta.  After the load was finished, when it rebooted, it would not boot from the drives.

    I have an HP DL360-G7 with the P410i SAS controller with a couple of drives in a mirror configuration.  UFS loads fine, but I can't seem to load the ZFS version.

    I will attach a screen shot of the error, and I am curious is anyone knows of a solution.  I tried reloading again, same error..



  • Rebel Alliance Developer Netgate

    These sorts of errors are almost universally related to your BIOS. You can try using a different Partition Scheme in the ZFS options when installing, but that's about all you can do at that point.

    Update your BIOS if you can.


  • Banned

    Also, perhaps disabling any sort of RAID might help. (No idea about the particular server, might need to do a single-drive RAID-0 for each of the drives.) Using "hardware" RAID with ZFS is not really a good idea anyway.



  • As really PFsense seems to just use a single main filesystem anyway, I just loaded it up with UFS instead of ZFS, as drive redundancy is handled by the RAID controller itself.  Just funny that UFS will just boot and run, but selecting ZFS ends up with a non-working system.  I have another almost identical server, but it's running Ubuntu, but with a ZFS root, and it boots just fine, so a FBSD quirk for sure..


Log in to reply