Issues With External VPN Connections – PF Sense Behind Cisco Router



  • Needing assistance trying to get remote connections to successfully connect. Currently have a Cisco Router with Gi 0/0/0 going out to the WAN link with our only public IP address. Default route sends all traffic out of this interface. I've looked at several PF Sense documents on setting up the VPN Server and believe that the PF Sense side is correct, but I don't see much documentation on how to do the static NAT translation on the router side. Wondering if the below statement looks correct (the last line). Any assistance would be greatly appreciated.

    !
    interface GigabitEthernet0/0/0
    description WAN side
    ip address x.x.x.170 255.255.255.248
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip verify unicast reverse-path
    ip access-group 110 in
    load-interval 30
    negotiation auto
    ip virtual-reassembly
    !
    !
    interface GigabitEthernet0/0/2
    description LAN Side
    ip address 10.20.0.1 255.255.255.252
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    negotiation auto
    ip virtual-reassembly
    !
    ip nat inside source list 1 interface GigabitEthernet0/0/0 overload
    ip nat inside source static udp 10.20.0.2 1194 x.x.x.170 1194 extendable



  • I have your scenario working reliably on a 867

    Differences I can see from my config to yours

    
     ip virtual-reassembly
     ip virtual-reassembly in
    
    
    
    ip nat inside source static udp 10.20.0.2 1194 x.x.x.170 1194 extendable
    ip nat inside source static udp 10.20.0.2 1194 interface GigabitEthernet0/0/0 1194
    
    

    (Assuming 10.20.0.2 is your pfSense box, which it could only be with 252 mask)

    Plus you need the access-list or access-group permit udp 1194 stuff