My phone seems to connect to PFsense ipv6 and won't work



  • Hey guys, I used the client export utility and have a pfsense config file.  I load it on all my tablets and phones.  Everyone of them except one connects to pfsense, grabs an IPv4 address and can connect to my cameras and webgui.  On my new Galaxy S7, it seems to connect with PFsense but seems to use IPv6 even though all IPv6 is disabled on my network.  Does anyone have any idea how to change android to disable ipv6?  I am pretty sure that is what is going on.  Any help would be much appreciated as this is my main phone and I cannot connect to my network anymore.



  • what android client?



  • openvpn for Android.  I managed to get the phone to connect and look like my other devices connection logs, by not using my dynamic DNS.  If I put my actual WAN IP, it seems to connect and look like I get an IPV4 address but I still cannot access my router or my cameras like all my other devices can.  Here is a picture of the connection log.




  • Hey guys, still haven't figured this out.  What is really weird and maybe this might help diagnose the problem, is it only happens when on my cellular network.

    If I connect to a wifi (at work or anywhere)  the PFsense VPN works and I can view my home cameras, log into the webgui, etc.  My IP comes up as my home networks WAN IP and everything works as expected.  If I disconnect from WIFI and go back using LTE cellular, I open up the VPN and it always shows my cell phone carriers IP (looks like IPv6) and I cannot connect to my cameras or my webgui.

    Any ideas? this is very frustrating.  We are going on a vacation next week and would REALLY love to get this ironed out by then.  Any help would be very much appreciated.



  • I figured out the problem guys, if anyone is interested.

    I guess my wireless carrier is utilizing some IPv6.  In the APN settings on my cell phone, it was set to IPv6/IPv4.  As soon as I set it to IPv4 only, my VPN started working as normal over the cell network.  It may be a bandaid solution but at least it is all working now.


Log in to reply