Client en FTPES



  • Bonsoir tout le monde !

    Je me pose quelques questions à propos de transferts en ftpes en tant que client, je ne parviens plus à me connecter sur un serveur distant chiffré depuis quelques temps, cela marchait "avant" mais avant quoi, je ne suis pas sûr; C'était peut être les quelques minutes d'essai que j'ai faites sans pare feu avant de me brancher au travers de pfsense (sur une alix2c3)
    Bref, je pars du principe que le serveur en face fonctionne, mais je vais me renseigner en même temps.

    Lorsque je demande une connexion j'ai:
    Commande : AUTH TLS
    Réponse : 234 AUTH TLS successful
    Statut : Initialisation TLS…
    Commande : USER epy
    Erreur : Délai d'attente expiré
    Erreur : Connexion au serveur impossible !
    Tout à l'air bon, (authentification etc)
    Mais le TLS ne passe pas, serait-ce un problème de certificat ou un port à rediriger sur ma machine ?

    J'ai laissé la règle par défaut qui laisse passer les connexion depuis le LAN vers l'extérieur, et j'ai une règle NAT (et les deux règles de pare feu automatiquement créées associées) qui redirige mon port 21 sur mon serveur ftp dédié (bizarrement je n'ai pas eu à ouvrir le port 20 comme j'ai pu le lire ici)

    J'ai fait une capture des paquets depuis pfsense pour voir ce qui se passe. C'est apparement un ACK qui n'est jamais reçu.

    La connexion sur d'autres ftp, distants ou le local fonctionnent sans problème (tous sans chiffrement).
    Auriez-vous quelques infos ou tests supplémentaires à me faire faire ?
    Merci :)



  • Question fréquemment posée dans la partie US :

    http://forum.pfsense.org/index.php/topic,3017.0.html



  • Arg  :o
    j'avais cherché pourtant, désolé (Je n'avais pas cherché avec ssl)

    Merci

    Edit: ça fonctionne en désactivant FTP-Helper sur l'interface LAN, cool :)



  • Quand on demande poliment et en bon français celà ne me gène pas d'aller chercher la réponse.

    Bonne continuation à vous.

    ;)


Locked