Bug? php problem with squid and squidguard



  • Since I upgraded my pfSense installation to version 2.4 I get errors on the Squid local host tab. Pfsense crashes with the following message:

    Warning: sprintf(): Too few arguments in /usr/local/www/classes/Form/Input.class.php on line 121 Call Stack: 0.0005 230576 1. {main}() /usr/local/www/pkg_edit.php:0 0.2809 3058896 2. Form_Input->setHelp() /usr/local/www/pkg_edit.php:750 0.2810 3059824 3. call_user_func_array:{/usr/local/www/classes/Form/Input.class.php:121}() /usr/local/www/classes/Form/Input.class.php:121 0.2810 3060208 4. sprintf() /usr/local/www/classes/Form/Input.class.php:121

    Something like this allso happens in Squidguard on multiple tabs.

    The /usr/local/www/classes/Form/Input.class.php file from version 2.3.2 has no problems, but is not working with the rest of the interface :)

    Is this a known problem that has to be solved with altered packages or am I missing something?



  • Same issue.

    Warning: sprintf(): Too few arguments in /usr/local/www/classes/Form/Input.class.php on line 121 Call Stack: 0.0000 232568 1. {main}() /usr/local/www/pkg_edit.php:0 0.0241 2579424 2. Form_Input->setHelp() /usr/local/www/pkg_edit.php:750 0.0241 2580384 3. call_user_func_array:{/usr/local/www/classes/Form/Input.class.php:121}() /usr/local/www/classes/Form/Input.class.php:121 0.0241 2580784 4. sprintf() /usr/local/www/classes/Form/Input.class.php:121

    squid 0.4.35_3

    Current Base System 2.4.0.b.20170206.0440
    Latest Base System  2.4.0.b.20170206.0440

    Issue resolved with Current Base System 2.4.0.b.20170207.0536 Latest Base System 2.4.0.b.20170207.0536



  • A fix is already in the pipeline:
    https://redmine.pfsense.org/issues/7202

    Make sure that pages you are having trouble with have been identified in that ticket.



  • okay, thanks



  • There are other problem with this block of text appearing throughout many pages below options on the WebConfigurator:

    Project-Id-Version: PACKAGE VERSION Report-Msgid-Bugs-To: POT-Creation-Date: 2017-02-06 09:41-0200 MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit PO-Revision-Date: 2017-02-03 05:17-0500 Last-Translator: Jim Thompson Language-Team: English (United States) Language: en-US X-Generator: Zanata 3.9.6 Plural-Forms: nplurals=2; plural=(n != 1)



  • @tadaog:

    There are other problem with this block of text appearing throughout many pages below options on the WebConfigurator:

    Project-Id-Version: PACKAGE VERSION Report-Msgid-Bugs-To: POT-Creation-Date: 2017-02-06 09:41-0200 MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit PO-Revision-Date: 2017-02-03 05:17-0500 Last-Translator: Jim Thompson Language-Team: English (United States) Language: en-US X-Generator: Zanata 3.9.6 Plural-Forms: nplurals=2; plural=(n != 1)

    That is an issue when the translation engine tries to translate an empty string. It should be fixed by PR https://github.com/pfsense/pfsense/pull/3484 which was only merged 4 hours ago.



  • In pages redirected by SquidGuard to http://<pfsense_ip>:80/sgerror.php, instead of PHP executing the code, nginx delivers the php source code.</pfsense_ip>


  • Banned

    @tadaog:

    In pages redirected by SquidGuard to http://<pfsense_ip>:80/sgerror.php, instead of PHP executing the code, nginx delivers the php source code.</pfsense_ip>

    ::) ::) ::)



  • Sorry, you're right! i'm posting to a new topic



  • Original problem solved with latest update

    2.4.0.b.20170208.0843

    :)



  • @papadeeh:

    Original problem solved with latest update

    2.4.0.b.20170208.0843

    :)

    All screens cleaned up!