Bad OpenVPN client configuration prevents other services starting during boot



  • As in title. The steps that lead to this:

    • I created an OpenVPN client config using the web interface.

    • Checked the status page to see if everything worked. The OpenVPN service was listed but not started.

    • Tried starting the OpenVPN service but it wasn't working so I thought I'll just reboot the system before debugging.

    • After reboot I could not load the web interface.

    • I was able to SSH and reboot the web interface from there which got it working.

    • Upon logging in, every service (except dpinger I think?) was not running.

    • Rebooted from the web interface and again web interface didn't work so I had to use SSH again to get it going.

    • Disabled the OpenVPN client config I just recreated and rebooted: Everything came up properly and was working again.

    • Re-enabled the OpenVPN client config to recreate the problem.

    • Web interface didn't work again but I also could not SSH in anymore. So I guess that the service is not starting this time either.

    So as of now, I am unable to pull logs or check and see if the problem occurs when the OpenVPN config is correct.

    I'll try getting in again with the console cable when I get some time later.

    Details:
    SG-1000
    2.4.0.b.20170205.1945