SquidGuard does not start



  • Hello,
    I configured SquidGuard and followed this solution (https://forum.pfsense.org/index.php?topic=94312.0), but the state of SquidGuard stays at SquidGuard service state: STOPPED.

    Things I did:

    • Checked this option to enable squidGuard.

    • Target Rules: !Dummy !blk_blacklists_ads !blk_blacklists_spyware all

    • Rebooted multiple times

    • Reinstalled the package

    Any ideas?

    –---------
    Filter Log:

    06.02.2017 18:18:09 squidGuard stopped (1486423089.460)
    06.02.2017 18:18:09 db update done
    06.02.2017 18:18:09 squidGuard 1.4 started (1486423089.449)
    06.02.2017 18:08:32 squidGuard stopped (1486422512.086)
    06.02.2017 18:08:32 db update done
    06.02.2017 18:08:32 squidGuard 1.4 started (1486422511.806)
    06.02.2017 18:06:49 squidGuard stopped (1486422409.353)
    06.02.2017 18:06:49 db update done
    06.02.2017 18:06:49 squidGuard 1.4 started (1486422409.341)
    06.02.2017 18:06:14 squidGuard stopped (1486422374.767)
    06.02.2017 18:06:14 db update done
    06.02.2017 18:06:14 squidGuard 1.4 started (1486422374.761)



  • I'm facing the same problem, but I had a working configuration before it stopped working.

    07.02.2017 07:13:03	squidGuard stopped (1486447983.392)
    07.02.2017 07:13:03	db update done
    07.02.2017 07:13:03	squidGuard 1.4 started (1486447983.388)
    07.02.2017 00:35:03	squidGuard stopped (1486424103.547)
    07.02.2017 00:35:03	db update done
    07.02.2017 00:35:03	squidGuard 1.4 started (1486424103.544)
    07.02.2017 00:32:35	squidGuard stopped (1486423955.070)
    07.02.2017 00:32:35	db update done
    07.02.2017 00:32:35	squidGuard 1.4 started (1486423955.068)
    07.02.2017 00:32:20	squidGuard stopped (1486423940.605)
    07.02.2017 00:32:20	db update done
    07.02.2017 00:32:20	squidGuard 1.4 started (1486423940.602)
    


  • Is it filtering URLs as expected?



  • No, no entries in the blocked log, and they are not being filtered properly when testing on clients either.

    I'll try with the new release of SquidGuard and see if that helps.



  • Hi there I'm having the same problem, I tried to reinstall the package and is working but is not filtering (supposed a bug on the config) don´t know what to do please help.



  • Same issue, the squidguard service just won't start.


Log in to reply