Switch ethernet kartı gibi kullanma ?



  • Arkadaşlar pc üzerinde yeteri kadar ethernet kartı olmadığı için elimizdeli layer 3 destekli switchi pfsense ethernet kartı olarak kullanmak istiyoruz.

    Switch : HP V1910-48G Switch JE009A
    Pfsense : 2.3.2-RELEASE
    Vmware Esxi  : 6.0

    Şimdi yapmam gereken nedir acaba  Switch üzerinde vlan oluşturup  esxi bunu tanıtım  pfsense makinaya bu etherneti tanıtmakmı lazım buna benzer bir yapıyı kuran oldumu neler yapmam lazım.

    iki adet portu pfsense ethernet karı olarak göstermem lazım

    portun birine ikinci wan hattı gelecek ve load balance yapacaz
    diğer porta ise access point takılıp wifi yayını yapacak .

    yardımlarınızı bekliyorum



  • Merhaba,

    Switch'te aşağıdaki şekilde bir conf yazmanız gerekir.

    2 Adet vlan oluşturun.

    • VLAN 10

    • VLAN 20

    VLAN10 1 port untagged
    VLAN20 2 port untagged

    VLAN10,VLAN20'i bir porta tagged duruma getirin. Örneğin : 24 port'a VLAN10 ve VLAN20 tagged durumda olsun.

    Bu VLAN'lar için interface olarak bir ip adresi atayın veya dhcp-bootp olarak tanımlayın. Akabinde 24 Port'tan aldığınız kabloyu VMWare Esxi üzerindeki pfSense tanımlı olarak interface set edin.

    Burada iki seçeneğiniz var VLAN10 ve 20 interfacelerini ister Esxi üzerinde sonlandırın isterseniz pfSense üzerinde sonlandırın. Ama buradaki her iki seçenek içinde konfigurasyon değişiklik gösterecektir.

    Saygılar.



  • Samet bey mevcut durumda pfsense çalışır durumda ve üzerinde 3 ad ethernet kartı var.

    1- wan
    2 - lan
    3- lan - acces point takılı

    şimdi yeni bir hat ihtiyacımız var ve ethernet portumuz yok yeni gelecek olan hattı switche 24 nolu porta taksak . bu hat  mevcutta bağlı olan lan bacağı üzerindenmi geçip pfsense ulaşacak bu tarafı tam anlayamadım.



  • @hakankaya:

    Samet bey mevcut durumda pfsense çalışır durumda ve üzerinde 3 ad ethernet kartı var.

    1- wan
    2 - lan
    3- lan - acces point takılı

    şimdi yeni bir hat ihtiyacımız var ve ethernet portumuz yok yeni gelecek olan hattı switche 24 nolu porta taksak . bu hat  mevcutta bağlı olan lan bacağı üzerindenmi geçip pfsense ulaşacak bu tarafı tam anlayamadım.

    Merhaba,

    LAN ve AP'nin takılı olduğu arabirimin network bilgilerini paylaşırmısınız. ? Size uygun bir conf paylaşacağım.



  • Lan ağı : 192.168.1.0/24
    Ap Ağı : 11.0.0.0/24

    Ap de Hızlimitleri mevcut



  • Merhaba,

    Kullandığınız switch de CLI varmı bilmiyorum ama HP switch için aşağıdaki confu paylaşıyorum.

    
    conf
    vlan 100 name LAN
    vlan 200 name GUEST
    vlan 300 name WAN2
    vlan 100
    ip address dhcp-bootp
    tagged 48
    untagged 1-40
    vlan 200
    ip address dhcp-bootp
    tagged 48
    untagged 40-42
    vlan 300
    ip address dhcp-bootp
    tagged 48
    untagged 43-44
    wr memory
    
    

    Bu işlemleri yaptıktan sonra 48. Porttan aldığınız kabloyu pfSense'in lan arabimine takıp. Interfaces -> VLAN menüsünden Switchde oluşturduğunuz vlanlari belirtip LAN,GUEST ve WAN2 arabirimlerini oluşturmanız gerekiyor.

    Akabinde Firewall -> Rules bölümüne girip ilgili Arayüzler için Firewall kurallarınızı yazın ve DHCP Sunucusunu yapılandırmanız yeterli.