Captive Portal Page won't be shown



  • Hi there,

    i try to use pfsense as captive portal for guest-access. so i got 3 interfaces, wan, lan (management) and glan (opt1. For the GLAN-Interface pfsense is DHCP-Server. when i turn of the CP, clients get an ip-adress via GLAN and can surf to the internet. But when i activate the CP in that setup for that interface, the client can not connect to the CP. the webpage won't be shown. no error in CP-log appears. I've no more Idea what to do :( How can i debug why the CP is not shown?



  • pfsense needs to be the dns server on a CP-enabled-interface



  • holy shit :/ I saw at the config-page of pfsense that i need to have an dns-forwarder active. this was the reason i didn't thaout about it… but it`s simpel... and it won't work without manipulating dns... so i lay down my self to bed again, as we say in germany.. tnaks a lot...



  • @klm46:

    Hi there,

    i try to use pfsense as captive portal for guest-access. so i got 3 interfaces, wan, lan (management) and glan (opt1. For the GLAN-Interface pfsense is DHCP-Server. when i turn of the CP, clients get an ip-adress via GLAN and can surf to the internet. But when i activate the CP in that setup for that interface, the client can not connect to the CP. the webpage won't be shown. no error in CP-log appears. I've no more Idea what to do :( How can i debug why the CP is not shown?

    It's even moire simple : https://doc.pfsense.org/index.php/Captive_Portal_Troubleshooting (the help page, as you requested).
    As stated : First issue : "Captive portal not redirecting ?" => "DNS resolution not functioning" will solve many issues  ;D


  • Netgate

    pfSense does not need to be the DNS server. But it is usually easier.

    If pfSense is not the DNS server, the DNS server(s) assigned to the clients need(s) to be passed through the captive portal by IP address so DNS queries can succeed prior to captive portal login.