Wait time when end hardtime captiportal



  • Hi everybody,

    Im using captive portal, its working well but have only issue as:
    I setup hardtime limit about 8 hours, when end time, client auto disconnect internet. Client need reauthent before use internet again.
    But almost they need wait about 10-30 mins that reconnect to wifi
    Why?



  • @nhimcoi30889:

    But almost they need wait about 10-30 mins that reconnect to wifi

    Why do you think the Wifi (radio) connection is related to pfSense ?
    Is your Wifi adapter integrated into the pfSense system ?



  • Dear Gertjan,

    i think that because my pfsense on PC and my Wifi is only AP. DHCP from Pfsense and AP unlimit



  • @nhimcoi30889:

    Dear Gertjan,

    i think that because my pfsense on PC and my Wifi is only AP. DHCP from Pfsense and AP unlimit

    PC with built in Wifi ? All depends if the OS used (FreeBSD) offers good support for your Wifi materiel. Don't use the build in Wifi and your problem will be solved.
    Using a PC is fine, just ADD some NICs - they cost about nothing - and use dedicated AP's.



  • No, i dont use build in wifi on PC. My pc is only Pfsense 2.3.2-p1. It has 3 NICs card. 1 for WAN , 1 for LAN and 1 for Wifi. All wifi device is Unifi AC LR



  • Now that things become more clear :
    @nhimcoi30889:

    ….
    But almost they need wait about 10-30 mins that reconnect to wifi
    Why?

    The "wifi" connection is only AP <=> PC-device related.
    The Wifi (radio) connection is controlled by you AP (and its setup).

    Btw : the pfSEnse DHCP  server is running on the "wifi" lan, right ?
    The DHCP in your AP is stiopped, right ?
    The gateway is set to pfSense (the Wifi NIC) ?
    Same for the DNS server in the AP.



  • @Gertjan:

    Now that things become more clear :
    @nhimcoi30889:

    ….
    But almost they need wait about 10-30 mins that reconnect to wifi
    Why?

    The "wifi" connection is only AP <=> PC-device related.
    The Wifi (radio) connection is controlled by you AP (and its setup).

    Btw : the pfSEnse DHCP  server is running on the "wifi" lan, right ?
    The DHCP in your AP is stiopped, right ?
    The gateway is set to pfSense (the Wifi NIC) ?
    Same for the DNS server in the AP.

    Dear Gertjan,
    The "wifi" connection is only AP <=> PC-device related.
    Btw.  the pfSEnse DHCP  server is running on the "wifi" lan, right ? ==> yep, but another range
    The DHCP in your AP is stiopped, right ? ==> alway stop
    The gateway is set to pfSense (the Wifi NIC) ? ==> Gway is IP wifi NIC
    Same for the DNS server in the AP. ==> Use from Pfsense



  • What about disabling the AP all together ?
    Behave as a visitor with a device that has a LAN RJ45 NIC - llike a PC.
    Cable yourself up to a free NIC port on your AP (LAN NIC).
    Connect.

    Do you see the same behaviour ? (if so, the problem isn't your AP - and must be some some where else like vry uncommun pfSEnse setup, broken cables, etc )
    Or not ? => ditch the AP. Take a better one (like a very non-expense Linksys E1200 - ditch firmware, put in DD-WRT - and of you go)



  • Ok Tks Gertjan,
    i'll retry and feedback