Servers configured with features that require OpenVPN 2.4 will not work with Ope



  • Hello,

    I just created a new OpenVPN Server and in "Client Export" utility, I have this message : "Servers configured with features that require OpenVPN 2.4 will not work with OpenVPN 2.3.x or older clients. These features include: AEAD encryption such as AES-GCM, TLS Encryption+Authentication, ECDH, LZ4 Compression and other non-legacy compression choices, IPv6 DNS servers, and more."

    I do not understand because I have a server with an equivalent configuration on another pfSense (in same version), and I do not have this message.

    An idea ? I need it to be compatible 2.3.14

    My config :

    Thanks


  • Rebel Alliance Developer Netgate

    The new version of the export package includes OpenVPN 2.4 binaries. They will work fine with OpenVPN 2.3.x servers.

    The message in that description is warning you that if you have an OpenVPN 2.4 server, and the OpenVPN 2.4 server has features enabled that are only in OpenVPN 2.4, then an older OpenVPN 2.3.x client may not work against that server.

    If your server is using OpenVPN 2.3.x you won't have anything to worry about and you can use either OpenVPN 2.4 or 2.3.x clients.



  • @jimp:

    The new version of the export package includes OpenVPN 2.4 binaries. They will work fine with OpenVPN 2.3.x servers.

    The message in that description is warning you that if you have an OpenVPN 2.4 server, and the OpenVPN 2.4 server has features enabled that are only in OpenVPN 2.4, then an older OpenVPN 2.3.x client may not work against that server.

    Thanks for this explication It's ok
    Have a nice week-end,


Log in to reply