Web Configuration Page won't Load using OpenVPN



  • Hello,

    I just recently installed pfSense. I do not have any packages installed at this moment except for the OpenVPN Client Export. I added OpenVPN Server to pfSense box following server tutorials I found using the wizard to create the necessary rules and certs. In my opinion all seems fine with the OpenVPN setup as I'm able to make the tunnel connection using my Mobile Phone and pinging my firewall at the default gateway 10.10.0.1. When using my Samsung s6 default internet browser and Chrome browser I am unable to have the pfSense Web Configuration page loading. I notice the progress moving for a short bit then stops with out loading. I reviewed the firewall logs and all seems OK. I haven't tweaked any of the settings for all the default services after the installation so may be there is some settings that are required which I am unaware of. Any help would be much appreciated as I have been struggling with this for sometime now.






  • I have this same issue, but only for TAP tunnels, the TUN tunnels can all access the web UI just fine.



  • Does anyone here have any idea why my Web Gui won't load using VPN. Anyone else with the same issue. Again any help would be much appreciated.

    Thanks,



  • Hilarious - the ONLY thing I can get to load via VPN is the web gui. I can't route any traffic to my local LAN, only to the pfsense box itself.

    I believe I have the EXACT OPPOSITE problem as you.

    :-\



  • from the lack of response on the forums and the IRC channel, asked nightly for weeks on end I have come to the conclusion nobody gives a damn and will be finding a differing distribution.. perhaps a fork… and using that instead.



  • Did you check the routing table of pfsense?  Did you try pings?  Can you ping the pfsense host?  Hosts behind pfsense?  Based on your screenshots, the traffic is being accepted so that makes me think the routing table isn't correct.  Or maybe you've got policy based routing rules that are forcing the traffic back thru something other than the ovpn tunnel?  Have you tried using a packet sniffer to trace what's going on with the packets?  Have you tried a traceroute from pfsense back to the client?  That should answer the routing questions/concerns.

    Based on your screenshots, you're close and it's probably something minor preventing things from working as expected.



  • You're not offering much information about your exact set up, no wonder you're not getting any response. Try a bit harder.



  • You're not offering much information about your exact set up, no wonder you're not getting any response. Try a bit harder.

    Let me start by saying that I am far from being a firewall guru. I've been at this for a week with the time I have available to me. If you need any information from me regarding my setup I would be glad to give it to you.

    All I can tell you is that when I use my mobile phone on my carriers network I am unable to load the pfSense Web Configuration web page nor my wireless router Web Configuration web page. But if i go to a public open wireless network like a coffee shop , I'm able to open up the webpage.

    Tunnel network: 192.16.4.0/24
    local network: WLAN 192.168.2.0/24
    local network: LAN 10.10.0.0/24

    when I have a tunnel connection. I'm able to ping from my phone to 192.168.2.1

    Regards,








  • I have a partial snap shot of my route table. Is link#10 interface lo0 correct or should it be ovpns1?




  • Hello,

    Well I finally found a solution for the web configuration page load problem. I found on google a suggestion which finally worked for me. What I did was decrease the MTU under General Configuration on the WAN interface which is by default blank (1500) down to 1380. This was the trick for me.