Доступ к локальным ресурсам провайдера



  • Доброго времени суток уважаемые.

    Если что прошу сильно не пинать, будем считать что я начинающий :).

    Имеется следующая проблема, есть два провайдера, сделан multiwan, у одного из провайдеров есть локальные ресурсы к которым бы хотелось получать доступ.
    Проблема в том что, по IP ресурсы доступны, но не по именам, точнее даже не так…, с DNS Lookup как ввожу имя IP показывается, Tracerout и Ping тоже показывают IP, если же пытаюсь сделать тоже самое с локального компа то не выходит, пишет "При проверке связи не удалось обнаружить узел", ощущение что упустил что-то банальное, но не пойму что...



  • Доброе.
    Скрины настроек интерфейсов, правил fw.



  • Да и также как у вас настроены DNS на клиенте и маршрутизаторе.



  • @werter:

    Доброе.
    Скрины настроек интерфейсов, правил fw.

    @PbIXTOP:

    Да и также как у вас настроены DNS на клиенте и маршрутизаторе.

    Хорошо добавляю информацию, провайдер к локальным ресурсам которого нужно оставить доступ (наш местный провайдер) выдаёт мне серый IP по DHCP, после чего поднимаю PPPoE для доступа в интернет.
    Второй провайдер Ростелеком, это оптика на железку HG8245H, железку я перевёл в режим бриджа, от неё тоже шнур во вторую сетевую на роутере, если её подцепить как интерфейс то IP не показывает, по этому сразу делаю PPPoE для выхода в интернет.

    Вот настройки серого IP и PPPoE первого провайдера и PPPoE Ростелкома:














  • Локальный компьютер получает IP по DHCP с роутера, DNS адрес тоже адрес роутера.
    На роутере в General Setting указаны IP DNS которые получают интерфейсы через PPOE, и использую я DNS Resolver
    Единственное что добавил это статический маршрут (Static Routes) для локальных ресурсов

    ![General Setting.jpg](/public/imported_attachments/1/General Setting.jpg)
    ![General Setting.jpg_thumb](/public/imported_attachments/1/General Setting.jpg_thumb)
    ![DNS Resolver.jpg](/public/imported_attachments/1/DNS Resolver.jpg)
    ![DNS Resolver.jpg_thumb](/public/imported_attachments/1/DNS Resolver.jpg_thumb)
    ![Static Routes.jpg](/public/imported_attachments/1/Static Routes.jpg)
    ![Static Routes.jpg_thumb](/public/imported_attachments/1/Static Routes.jpg_thumb)



  • Странно что ping и tracert проходят, а соединения нет.
    Тогда саммый простой вариант снимайте просто дамп трафика проходящего через маршрутизатор, он скорее всего покажет ваши ошибочные настройки.



  • @PbIXTOP:

    Странно что ping и tracert проходят, а соединения нет.
    Тогда саммый простой вариант снимайте просто дамп трафика проходящего через маршрутизатор, он скорее всего покажет ваши ошибочные настройки.

    Не совсем так, не проходят ping и tracert по имени, но если указать IP то всё работает, конечно можно работать и напрямую с IP, но это не сильно удобно, и так же бы хотелось разобраться в чём проблема.
    Вы бы ещё подсказали как этот дамп лучше снять…:)



  • @Uranus:

    @PbIXTOP:

    Странно что ping и tracert проходят, а соединения нет.
    Тогда саммый простой вариант снимайте просто дамп трафика проходящего через маршрутизатор, он скорее всего покажет ваши ошибочные настройки.

    Не совсем так, не проходят ping и tracert по имени, но если указать IP то всё работает, конечно можно работать и напрямую с IP, но это не сильно удобно, и так же бы хотелось разобраться в чём проблема.
    Вы бы ещё подсказали как этот дамп лучше снять…:)

    Скорее всего провайдер поленился опубликовать нормальные DNS записи в Интернете о своей сети.
    Воспользуйтесь "Domain Overrides" для сайта провайдера



  • @PbIXTOP:

    @Uranus:

    @PbIXTOP:

    Странно что ping и tracert проходят, а соединения нет.
    Тогда саммый простой вариант снимайте просто дамп трафика проходящего через маршрутизатор, он скорее всего покажет ваши ошибочные настройки.

    Не совсем так, не проходят ping и tracert по имени, но если указать IP то всё работает, конечно можно работать и напрямую с IP, но это не сильно удобно, и так же бы хотелось разобраться в чём проблема.
    Вы бы ещё подсказали как этот дамп лучше снять…:)

    Скорее всего провайдер поленился опубликовать нормальные DNS записи в Интернете о своей сети.
    Воспользуйтесь "Domain Overrides" для сайта провайдера

    Если честно не думаю, DNS Lookup с PFSense показывает IP когда ввожу имя, тут скорее что то с маршрутизацией, вопрос только что.



  • Доброе.
    Укажите в настр. своей сетевой карты руками адреса локальных днс провайдера (вы же их пингуете, да? )
    А также создайте на лан пф правило, разрешающее лоступ к лок. сети провайдера. И выложите скрин этих правил здесь.



  • @werter:

    Доброе.
    Укажите в настр. своей сетевой карты руками адреса локальных днс провайдера (вы же их пингуете, да? )
    А также создайте на лан пф правило, разрешающее лоступ к лок. сети провайдера. И выложите скрин этих правил здесь.

    Если вы под "настр. своей сетевой карты руками адреса локальных днс провайдера" имеете ввиду ввести эти адреса в настройках карты на локальном компьютере который стоит за PFSense то я так сделал (и да они пингуются и с локального компьютера и с PFSense), добавил разрешающие правила в Firewall-Rules для Lan, когда в списке DNS на сетевой карте первыми или даже первым стоит хоть один из IP-DNS провайдера с локальными ресурсами то всё пингуется по именам, стоит поставить как DNS IP PFSense и пинги по именам опять не проходят пишет (При проверке связи не удалось обнаружить узел)
    Извините…, скрины пока кинуть не могу, чуть позже если всё ещё надо (работы много  :'( ).



  • Доброе.
    @Uranus:

    стоит поставить как DNS IP PFSense и пинги по именам опять не проходят пишет (При проверке связи не удалось обнаружить узел)

    Все верно. У вас в настройках pf стоит галка на переопределение dns при поднятие pppoe-сессии. Снимите ее и укажите лок. адреса днс провайдера.



  • @werter:

    Доброе.
    @Uranus:

    стоит поставить как DNS IP PFSense и пинги по именам опять не проходят пишет (При проверке связи не удалось обнаружить узел)

    Все верно. У вас в настройках pf стоит галка на переопределение dns при поднятие pppoe-сессии. Снимите ее и укажите лок. адреса днс провайдера.

    Так…, галочку в System - General Setup с параметра  "DNS Server Override - Allow DNS server list to be overridden by DHCP/PPP on WAN" убрал,
    "локальные днс адреса провайдера" это IP DNS серверов провайдера с локальными ресурсами ???
    Если да, то они собственно совпадают с теми которые мы получаем при поднятии сессии PPPoE этого провайдера, но сделал раз вы так говорите,  DNS сервера выше в System - General Setup - DNS Server Settings уже и так прописаны, что то ещё надо сделать, потому как пинги по имени по прежнему не проходят...

    Вот собственно распишу все:
    Два провайдера в мультелане:
    Ростелеком при поднятии PPPoE получает два DNS адреса, но он нам собственно не нужен
    Второй провайдер и при выдаче серого IP и при поднятии PPPoE выдаёт одни и те же DNS адреса, скажем 79.134.10.1, 79.134.10.2 и 10.0.0.1, локальные ресурсы этого провайдера находятся в диапазоне 192.168.0.0/16, как я и писал DNS адреса второго провайдера пингуются и с локального компьютера и с PFSense, с настройками которые показаны в скринах в выше расположенных постах у меня проходят пинги и tracerout на локальные ресурсы по IP, но не по именам.



  • Скрины правил fw.

    Зы. Кеш у себя почистите в Вин - _ipconfig /flushdn_s от имени Адм-ра.



  • @werter:

    Скрины правил fw.

    Зы. Кеш у себя почистите в Вин - _ipconfig /flushdn_s от имени Адм-ра.

    Чистка кеша не помогает…

    p.s.
    Простите..., скрины каких правил вам нужно...?



  • Отключить Dns Resolver, включить Dns Forwarder (dnsmask)натравить на dns прова,чьи ресурсы нужны. Не?



  • @Tank1337:

    Отключить Dns Resolver, включить Dns Forwarder (dnsmask)натравить на dns прова,чьи ресурсы нужны. Не?

    Спасибо, проверю и отпишусь получилось или нет…

    ....
    Чтож..., или я что то делаю не так (кстати если вам не лень напишите что я по Вашему должен был сдеалать окромя переключения с Dns Resolver на Dns Forwarder)
    или..., короче не получается, по прежнему работает только по IP, ещё раз напомню,  я как бы начинающий, если что пишите подробнее, то что для вас само собой разумеющееся для меня может быть и не понятно...



  • Сам я как бэ нубяра… Мультиван,пппое, днс резолвер... Надо сужать круг подозреваемых. Лучше попробовать с нуля поставить пф с минимальной настройкой(без мультивана и с днсмаск вместо резолвера). Перечитать эту ветку...



  • @Tank1337:

    Сам я как бэ нубяра… Мультиван,пппое, днс резолвер... Надо сужать круг подозреваемых. Лучше попробовать с нуля поставить пф с минимальной настройкой(без мультивана и с днсмаск вместо резолвера). Перечитать эту ветку...

    Проблема в том что мультиван то и нужен, или вы думаете что и без мультивана работать не будет потому что днс резолвер виноват?!
    Вообще то если поднимать PPPoE с одним провайдером на обычном компе то локальные ресурсы доступны, проблемы начинаются именно с несколькими провайдерами так как надо править маршрутизацию, что на Микротике что на PFSense…

    p.s.
    PFSense в работе, надо время выкраивать чтобы переустанавливать с нуля...