Captive Portal läuft nicht sauber



  • Hallo zusammen,

    ich verwendet pfsense hinter einer bestehenden FW.

    WWW –> Router --> FW (3 Netze) --> PFsense

    Ich würde gerne das Captive Portal nutzen.

    Sofern das Portal aus ist oder ich den Test Client der an der LAN Schnittstelle hängt unter Macs eintrage kommt dieser auch ins Internet.

    Leider bekomme ich die  Loginseite von Captive Portal nicht angezeigt

    Habt ihr da eine Idee?

    Gruß



  • Moin.

    Hast Du den DNS-Forwarder für das WLAN eingerichtet? Und dann mal eine Allow-all Rule für das WLAN-Netz eingerichtet? Ich hatte das gleiche Problem.

    Gruß
    Carsten



  • Moin Moin,

    DNS Forwarding ist aus.
    Ich hatte ja so mal die Seite angezeigt bekommen bsi gestern.

    Habe daraufhin nur den WebConfigurator auf https und auf nen anderen Port gelegt so wie SSH.
    HAbe noch den Consolen Login Enabled.

    Anschließend bekam ich eben die Seite nicht mehr angezeigt.

    Das Ganze läuft bei mir über die Normale LAN Karte dort ist ja alles Enabled.

    Update:
    IE kommt der Login Screen beim Firefox nicht.
    Ticketfeld fehlte -pf reboot Feld ist nun vorhanden.
    Login mit Ticket funktioniert , mit USer leider nicht. (Fehlermeldung: "Invalid credentials specified)

    NAch Login erschein nur ein  weisses Fenster.

    Gruß

    Mark



  • Benutzer ist aber angelegt? Hat der Benutzer das Recht, sich am Portal anzumelden (siehe Screenshot)?

    ![Bildschirmfoto 2017-02-22 um 15.54.44.png_thumb](/public/imported_attachments/1/Bildschirmfoto 2017-02-22 um 15.54.44.png_thumb)
    ![Bildschirmfoto 2017-02-22 um 15.54.44.png](/public/imported_attachments/1/Bildschirmfoto 2017-02-22 um 15.54.44.png)



  • Moin,

    Benutzer ist aber angelegt? Hat der Benutzer das Recht, sich am Portal anzumelden (siehe Screenshot)?

    Das war der Fehler Nummer 1.  –- Kann man das Recht auch über eine Gruppe zuweisen?

    Bleibt noch der Fehler warum bei Firefox keine Login Seite angezeigt wir und im IE sofort.

    Vielen Dank und Grüße

    MArk



  • Funktioniert die Seite auf anderen Browsern? Wie sieht es auf Mobilgeräten aus? Verwendest Du die Originalseite von PFSense?



  • Funktioniert die Seite auf anderen Browsern? Wie sieht es auf Mobilgeräten aus? Verwendest Du die Originalseite von PFSense?

    Habe IE und Firefox getestet IE ohne Probleme Firefox zickt halt rum.
    Mobilegeräte habe ich derzeit nicht in der Testumgebung.
    Ich verwende derzeit die Orginalseite.


Log in to reply