Pfsense даёт качать 40 секунд и обрывает



  • Pfsense 2.3.2-RELEASE (i386), 2 сетевые карты: LAN, WAN. После установки ничего не настраивал кроме сетевых интерфейсов. В качестве шлюза указывал отдельный роутер на котором поднятно PPPoE, так же пробовал указывать комп который сейчас работает в качестве шлюза и раздаёт интернет.

    В обоих случаях постоянно обрывается ICQ, тест скорости интернета проваливается, если поставить файл на скачку в браузере - качает 40 секунд и обрывается(замерял 3 раза). До этого ставил на виртуалку на другом компе - было всё тоже самое, т.е. проблемы в сетевухах нет.

    Как я понял он почему - то обрывает установленное соединение через 40 сек.

    На прямую без Pfsense всё работает отлично. Не пойму в чём дело, где что смотреть?

    –---------------------------------------------------------------

    P/S. Позже зашёл в "System/Advanced/Firewall & NAT", нашёл там в самом низу "State Timeouts (seconds - blank for default)" - поля пустые, поставил везде от балды 100 секунд - и…рваться соединение начало через 100 секунд. Убрал обртано, оставил поля опять пустыми - опять начало обрываться через 40 секунд, будто по дефолту(seconds - blank for default) в Pfsense где - то стоит значение в 40 секунд.

    Отключаю фаервол - проблема 40 секунд пропадает, включаю обратно появляется.


    В общем поставил в "Firewall Optimization Options" значение "Conservative" - проблема решилась. По умолчанию стояло "Normal", и с этой опцией у меня рвутся через 40 сек соединения.



  • PPPoE не падает на самом роутере?
    Если есть возможность - переведите роутер в бридж и поднимите PPPoE на pfSense, сравните результаты.



  • @pigbrother:

    PPPoE не падает на самом роутере?
    Если есть возможность - переведите роутер в бридж и поднимите PPPoE на pfSense, сравните результаты.

    Не падает. Я же пишу: указывал на pfsense шлюзом сначала роутер раздающий интернет, потом сервер раздающий интернет, результат один и тот - же: работает, но обрываются через 40 сек установленные соединения судя по всему(при этом пинг идёт без перебоев).

    Без pfsense всё работает нормально.



  • Зашёл в "System/Advanced/Firewall & NAT", нашёл там в самом низу "State Timeouts (seconds - blank for default)" - поля пустые, поставил везде от балды 100 секунд - и…рваться соединение начало через 100 секунд. Убрал обртано, оставил поля опять пустыми - опять начало обрываться через 40 секунд, будто по дефолту(seconds - blank for default) в Pfsense где - то стоит значение в 40 секунд.

    Отключаю фаервол - проблема 40 секунд пропадает, включаю обратно появляется.



  • А что в логах?



  • @pigbrother:

    А что в логах?

    В каких конкретно логах и как их посмотреть?



  • @chenc:

    @pigbrother:

    А что в логах?

    В каких конкретно логах и как их посмотреть?

    ???
    Status->System Logs



  • @pigbrother:

    @chenc:

    @pigbrother:

    А что в логах?

    В каких конкретно логах и как их посмотреть?

    ???
    Status->System Logs

    Мне непонятно что конкретно там смотреть и как интерпретировать для помощи в решении моей проблемы.

    В общем поставил в "Firewall Optimization Options" значение "Conservative" - проблема решилась. По умолчанию стояло "Normal", и с этой опцией рвутся через 40 сек соединения.



  • Такое ощущение, что в схеме сети где-то закралась ассиметричная маршрутизация



  • @PbIXTOP:

    Такое ощущение, что в схеме сети где-то закралась ассиметричная маршрутизация

    При асимметричной маршрутизации соединения вообще бы не установились, разве не так? Вообще в сети и правда есть 2 интернет - канала провайдерских, но асимметричную маршрутизацию можно исключить.

    В любом случае проблема уже решилась: в настройках pfsense :"Firewall Optimization Options" поставил значение "Conservative" и обрываться через 40 сек перестало. По умолчанию стояло "Normal", но лично у меня с этой опцией фаервол рвал установленные соединения через 40 секунд. Почему так - хз.

    Так было сначала на виртуалке, я тогда грешил на неё. Потом поставил на реальное железо - тоже самое. Могу отметить что в обоих случаях довольно слабые характеристики железа были, что виртуального, что реального - сейчас, например он запущен на железе с 2GB DDR2. Возможно фаервол pfsense при подобных конфигурациях железа считает что его не достаточно для длительных соединений, и с опцией по умолчанию обрывает их через 40 сек. Хотя монитор ресурсов пфсенса показывает что комп практически отдыхает. Но это только предположение.



  • довольно слабые характеристики железа

    Это врядли. Мой первый pfSense работал вообще на PIII с 416 МБ ОЗУ.
    25 Мбит, 2 WAN, несколько OVPNVPN - site-to-site + мобильные юзеры.



  • @pigbrother:

    довольно слабые характеристики железа

    Это врядли. Мой первый pfSense работал вообще на PIII с 416 МБ ОЗУ.
    25 Мбит, 2 WAN, несколько OVPNVPN - site-to-site + мобильные юзеры.

    Возможно от версии зависит. В общем непонятно почему так у меня происходит, в инете ничего подобного не нашёл. Но по факту проблема 40 секунд решается либо выбором другой опции в "Firewall Optimization Options" либо выставлением нужных значений в "State Timeouts", либо отключением фаервола полностью.