[SOLUCIONADO] Ayuda con Vlan para Balancear WAns en pfSense



  • Un saludo cordial estimado y apreciados compañeros usuarios de este foro.

    Me remito aquí porque necesito ayuda y he tratado de hacer pruebas, pero lamentablemente por ahora solo tengo el pfSense en producción, en este pfSense tengo 3 WAN balanceadas y una LAN, el problema es que mi proveedor empezó a bajar un poco sus límites de velocidad de subida, y ahora necesito más líneas, estas ya las he conseguido, y las he logrado balancear en un EdgeRouterX (5 puertos) de Ubiquiti, pero pensandolo bien, creo que puedo hacer todo desde el pfSense y utilizar los equipos como switch. la cosa está más u menos así, el diagrama esta hecho en paint lamento mucho que parezca de preescolar, espero sirva:

    Lo que quiero es hacer que el EdgeRouter sirva como medio para conectar los 4 adsl y llevarlos hasta el pfSense para que este los administre. Conectar del puerto que me queda libre del EdgeRouter a mi puerto libre en mi Touch Switch  PoE (5 puertos + el de administración). Como solo tengo un puerto libre en ambos aparatos un solo puerto, y lo que quiero hacer es llevar por medio de unas Vlans que pasen por mi Lan los 4 ADSL que están en el EdgeRouter por medio del 5to puerto el Switch, al puerto 1 que es mi Lan de mi pfSense. Pero la verdad es que me he dedicado estos últimos más a las cosas fisicas que las lógicas y aunque he tratado de hacer lo me ha salido, solo he logrado tirar mi servicio, y como no tengo un equipo para hacer pruebas, pues por eso recurro aquí a ver si me podrían ayudar.

    Les dejo imagenes:

    Este es mi pfSense:

    4 interfaces fisicas, 3 Gigabit, 1 base 100, 3 Wan 1 Lan


    Esta es la pestaña de las Vlans del EdgeRouter.


    Esta es la pantalla de las Vlan de mi Switch

    La del pfSense :P ;D

    Y estos son los puertos que tengo en mi Switch solo uno libre, en el EdgeRouter igual tengo solo uno libre, pero es el que ocupo como su lan o para administrar.

    De antemano muchas gracias.


    Editado

    Bueno, lo que quiero decir es que no tengo la menor idea de como y donde tengo que crearlas, las he creado en el pfsense, en el swith y en el EdgeRouterX, pero no logro hacer la gran cosa, más que tirar mi servicio, como todo sale por DHCP :(


  • Rebel Alliance

    @ZAC:

    lo que quiero hacer es llevar por medio de unas Vlans que pasen por mi Lan los 4 ADSL que están en el EdgeRouter por medio del 5to puerto el Switch, al puerto 1 que es mi Lan de mi pfSense

    Y para que "llevar" 4 "WAN" a la "LAN" ???

    Lo correcto sería…

    [Switch Manejable de 8 puertos] –---(trunk /con las 7 WAN's para balancear)----- [pfSense]–--(LAN)---[ToughSwitch / el resto de tu red]

    Respecto al tema "VLAN's"  en "Documentación" tienes info, revisa: "Ahorrando tarjetas de red, gestionando VLAN en switch y pfSense"

    Lo que respecta al "ER-X" lo buscas/consultas en el Foro de UBNT ;)



  • Muchas gracias ptt, si imagino que lo correcto hubiera sido un switch administrable más grande y pasarlas todas por una wan, pero de momento no hay $$$$$, así que pensaba en esa solución, si he leido la documentación y he tratado de implementarlas, pero la verdad no me sale como en los manuales, he visto un video que esta ahí en la documentación, y de verdad pense que eso aclararía todo mi panorama, pero tampoco me funciono, creo que entonces tendré que esperar a que caiga más efectivo y comprar un switch administrable con más puertos y pasar todas mis wans por ese switch y dejar mis otras tarjetas de red libres, ya que creo que no podré darle una solución viable como estoy ahora T_T



  • Existen tarjetas PCI ethernet de varios puertos Ethernet como la siguiente:

    Si queres que pfSense maneje las WAN, pues podrías pensar en colocar una o dos tarjetas de esa en el equipo para las WAN, e igual para crear VLAN a menos que podas adquirir algún switch administrable como te están recomendando.

    Saludos.



  • Si ya las he visto, pero he leido que no jalan con pfSense, al menos la que puedo comprar StarTech ST1000SPEX43, pero leí en Amazon un comentario que la StarTech ST1000SPEXD4 si que funciono, se supone que ambas deberían funcionar, pero la primera hay un post de 2014, que probo con la versión 2.2, ya era FBS 10, que no le funcionó, y la verdad es que cuestan una buena lana, sale más barato otro switch que la tarjeta, y la segunda, si sale más barata que un switch, aún y me daría margen de maniobrar o probar un poco más, ahora mismo ando pensando en si la encargo o no, (la segunda de nos puertos), porque si es una lana, y si no me jala, me la persino, por eso ando intentando lo de las Vlan xD, pero solo logro tirar mi servicio.



  • Hace como 8 meses o un año, traté de utilizar tarjetas ethernet por USB y no funcionaron dos de las que pude conseguir aquí con la versión 2.x de pfSense, no recuerdo cual era.  Usé eso porque el equipo donde quería ponerle, no tenía puertos PCI disponibles.  Era de un cliente que le pusimos pfSense en un equipo viejo porque no quería gastar y lógicamente, nosotros asumimos el costo de esas tarjetas Ethernet USB y nos quedamos con ellas.

    Hace como 2 meses me compré un equipo NUC Lenovo I5 usado a menos de la mitad de precio y volví a probar esas tarjetas USB ethernet y ambas me funcionaron.  Mejoraron el soporte de hardware de pfSense y eso me alegró mucho pero ya ese cliente lo perdimos por mala paga.

    Con eso solo quiero decirte que un artículo viejo, puede que diga no funcione algo pero solo probando se puede saber.

    Sé que el costo de esas tarjetas es elevado, pero entrando en Amazón vi una Intel a muy buen precio, mira:
    HP NC364T PCIe 4Pt Gigabit Server Adptr
    Network Cards

    Incluso, podrías buscar alguna usada en OLX, Mercado Libre o algún lugar de eso para no gastar tanto y hacer las pruebas.



  • Gracias por el dato, la he buscado en México y la encontré a un precio un poco superior, unos 21 dólares más cara, pero imagino que es por los gastos de importación, y todos esas cosas, y prefiero comprar algo ya importado en México que verme en problemas de aduana, una vez pedí algo que venía de China y jamás llego xD, así que creo que si voy a pedir esta tarjeta, me sale más barata que un switch administrable, y aunque no me soluciona mis problemas por completo si me da un respiro en lo que adquiero un switch administrable más grande o adquiero otro similar, muchas gracias por tu ayuda, y al parecer esa tarjeta si que funciona bien según un post y mucho más barata que las otras que había visto espero no me estafen en amazon xDDDD

    https://forum.pfsense.org/index.php?topic=12941.0



  • Pues no ha sido una solución inmediata, me llegara hasta el 7 de abril, así que mientras tengo tiempo de ahorrar para otro switch y seguir probando la manera de hacer funcionar esto xD


  • Rebel Alliance

    @ZAC

    Por lo que vi en el Foro de UBNT, tienes "Funcionando" el Balanceo en tu ER-X

    "Una que se me ocurre"  como prueba/posible "solución" temporal, es que conectes el ER-X en lugar de uno de los "Modems" (WAN) que tienes en el pfSense… con lo que te quedarán 2 Modems al pfSense, y una interface (WAN) con el ER-X y lo 4 Modems Balanceados... digo... te quedará un "doble NAT" pero podría llegar a funcionar ;)



  • gracias @ptt si lo tengo funcionando ya así, aunque me queda fuera un adsl, lo que ahora intento es que usado ER-X hacer que el pfSense haga todo, osea, usar el ER-X solo como el medio físico por el que se conecten, pero lamentablemente creo que no le entiendo muy bien a esto de las Vlan (aún, nada es para siempre xD), y no logro hacerlo, pero creo, se me hace que es que estoy haciendo doble trabajo, creo que solo tengo que marcar la Vlan en el ER-X y en el pfSense y no en Switch, o no se, voy a seguir probando, pero como tengo manera de probarlo en "laboratorio", y no me quiero a poner a descubrir como simularlo virtualizado, lo hago solo a ciertas horas de la madrugada cuando hay muy poco trafico, ya si no me sale sigo otro día, muchas gracias por su apoyo a ambos, de verdad.


  • Rebel Alliance

    A ver… Simplificando/Resumiendo...

    El ER-X como Switch, y el eth0 (Trunk) conectado directamente al pfSense:

    eth0 --> VLAN's 10, 20, 30, 40 (Trunk/Tagged) --> Interface del pfSense (Trunk/Tagged) con las mismas VLAN (10, 20, 30, 40)

    eth1 --> VLAN 10 (Access/Untagged) --> Modem 1

    eth2 --> VLAN 20 (Access/Untagged) --> Modem 2

    eth3 --> VLAN 30 (Access/Untagged) --> Modem 3

    eth4 --> VLAN 40 (Access/Untagged) --> Modem 4

    de esa manera, dispondrás de 4 "interfaces" (VLAN's) para asignar/utilizar como WAN en el pfSense, por lo que tendrás un total de 6 WAN's para "Balancear"  ;)

    Respecto a la "configuración" de VLAN's del ER-X, debería ser algo como:

    set interfaces switch switch0 switch-port interface eth0 vlan vid 10

    set interfaces switch switch0 switch-port interface eth0 vlan vid 20

    set interfaces switch switch0 switch-port interface eth0 vlan vid 30

    set interfaces switch switch0 switch-port interface eth0 vlan vid 40

    set interfaces switch switch0 switch-port interface eth1 vlan pvid 10

    set interfaces switch switch0 switch-port interface eth2 vlan pvid 20

    set interfaces switch switch0 switch-port interface eth3 vlan pvid 30

    set interfaces switch switch0 switch-port interface eth4 vlan pvid 40

    Lamentablemente, no tengo forma de "probar" pero un compañero del Foro UBNT, reportó que "a el le funcionó" de esa manera (en su caso con 2 VLAN's)



  • Muchas gracias @ptt al rato en la madrugada me doy una probada, si resulta, que espero que si, le debo una cerveza bien fría, virtual xD, porque está hasta la otra punta del continente xD



  • @ptt muchísimas gracias, ayer me quede dormido, pero hoy me he desvelado, y me ha quedado perfecto, gracias a lo que pego encontre unos post en el foro de ubiquiti que me ayudaron a entender el porque me daba un error, y listo, para hacer lo que me ha dicho había que poner dos cosas antes, pero listo, me quedo excelente. Utilice el puerto que usa la salida PoE por si acaso algún día tengo que sacar enlaces por un enlace xD, de verdad muchas gracias.

    Lo que ocupe en el CLI del ER-X fue lo siguiente

    
    configure
    set interfaces switch switch0 switch-port vlan-aware enable
    set interfaces switch switch0 switch-port interface eth0 vlan pvid 10
    set interfaces switch switch0 switch-port interface eth1 vlan pvid 20
    set interfaces switch switch0 switch-port interface eth2 vlan pvid 30
    set interfaces switch switch0 switch-port interface eth3 vlan pvid 40
    set interfaces switch switch0 switch-port interface eth4 vlan vid 10
    set interfaces switch switch0 switch-port interface eth4 vlan vid 20
    set interfaces switch switch0 switch-port interface eth4 vlan vid 30
    set interfaces switch switch0 switch-port interface eth4 vlan vid 40
    commit
    save
    exit
    

    Y en el pfSense solo puse las vlan con su ID y listo, no agregue nada más y funciona todo a la perfección.


    Por si alguien llega a este post con el mismo problema que yo, les dejo este enlace que me sirvió muchísimo para entender que estaba haciendo mal, aunque sin la ayuda del compañero ptt no lo hubiera logrado.
    https://help.ubnt.com/hc/en-us/articles/222484908-EdgeRouter-How-to-Configure-an-EdgeRouter-as-a-Switch



  • Teniendo en cuenta que mi proveedor tiene una fibra de 50 megas para todos usuarios (lo se porque me toco instalar ese carrier con mi cuadrilla y me toco ver las pruebas de velocidad antes de que migraran de las microondas) y que me dan por linea máximo 10 megas de descarga y 384kb de subida me parece que fue una muy buena maniobra, además ahora pienso que puedo instalar una torre en otro sitio en otra población contratar 4 servicios y mandarlos por vlan y que el pfSense las administre sin que me lo haga otro equipo, se ve más bonito, me gusto, que feliz se pone uno cuando le ayudan tanto  :)





    Lamentablemente es que no he dejado una manera para poder administrar o cambiar alguna configuración en el ER-X, pero bueno de mientras el objetivo esta logrado, y estoy muy agradecido con ello.


  • Rebel Alliance

    De nada ! @ZAC

    Para poder administrar el ER-X lo que "yo" haría es agregar una VLAN a la eth4 (Trunk) digamos la 50

    
    set interfaces switch switch0 switch-port interface eth4 vlan vid 50
    
    

    Y esa misma VLAN (50) al pfSense

    Al ER-X le asignas la IP (segmento de IP que quieres utilizar para manejarlo) en esa VLAN (50), al pfSense (VLAN 50) le asignas IP en ese segmento, y deberías poder acceder al ER-X…

    Esto es "simplificando" y "omitiendo" algunos detalles/pasos.... ya que no tengo forma de elaborar un "paso a paso"  ;)

    Me alegra haber sido de ayuda, y suerte con la implementación en el nuevo poblado.



  • Muchas gracias @ptt tratare de ponerlo en funcionamiento :), para no tener uno de estos bichos me ha ayudado muchísimo, si no, jamás hubiera podido hacerlo, de nuevo muchísimas gracias.


    Y como ya he solucionado mi problema, ¿podemos cerrar el hilo no?


  • Rebel Alliance

    De nada !

    Si quieres "Cerrar" el Tema/Hilo, abajo tienes el botón "Lock Topic" y con eso evitas que sigan "posteando/respondiendo"

    Si en algún momento decides Retomar el tema, lo puedes "desbloquear/abrir" (Unlock Topic)

    Esto únicamente lo puedes hacer Tú (Autor del Tema) o un "Moderador del Foro"

    ![Lock Topic.png](/public/imported_attachments/1/Lock Topic.png)
    ![Lock Topic.png_thumb](/public/imported_attachments/1/Lock Topic.png_thumb)
    ![Unlock Topic.png](/public/imported_attachments/1/Unlock Topic.png)
    ![Unlock Topic.png_thumb](/public/imported_attachments/1/Unlock Topic.png_thumb)


Locked