[fixed] 2.3.4.a.20170302.1710 (amd64) : fatal error on edit/add firewall rules



  • On 2.3.4.a.20170302.1710 (amd64) , if I try to add or edit a firewall rules I get, every time, this error:

    Catchable fatal error: Argument 2 passed to Form_Input::setHelp() must be of the type array,
    integer given, called in /usr/local/www/firewall_rules_edit.php on line 1503 and defined in /usr/local/www/classes/Form/Input.class.php on line 145
    Call Stack: 0.0004 231312 1\. {main}() /usr/local/www/firewall_rules_edit.php:0 0.2483 2505312 2\. Form_Input->setHelp() /usr/local/www/firewall_rules_edit.php:1503
    PHP ERROR: Type: 4096, File: /usr/local/www/classes/Form/Input.class.php, Line: 145,
    Message: Argument 2 passed to Form_Input::setHelp() must be of the type array, integer given, called in /usr/local/www/firewall_rules_edit.php on line 1503 and defined
    

    Same situation on two installations.


  • Rebel Alliance Developer Netgate

    I pushed a fix for it, you can apply it using the system patches package or wait for the next snapshot.

    https://github.com/pfsense/pfsense/commit/adb1945666136a26d1c69e7b3795160007bf5648



  • fix applied,
    IT WORKS!  :)
    Thanks!