Connection problem



  • Hello i have flowed the guide to the point and when i connect from a remote client i get this error

    Keep in mind that i am not so familiar with all that ;D

    Sat Oct 04 21:04:34 2008 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct  1 2
    006
    Sat Oct 04 21:04:34 2008 IMPORTANT: OpenVPN's default port number is now 1194, b
    ased on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earl
    ier used 5000 as the default port.
    Sat Oct 04 21:04:34 2008 WARNING: –ping should normally be used with --ping-res
    tart or --ping-exit
    Sat Oct 04 21:04:34 2008 LZO compression initialized
    Sat Oct 04 21:04:34 2008 Control Channel MTU parms [ L:1544 D:140 EF:40 EB:0 ET:
    0 EL:0 ]
    Sat Oct 04 21:04:34 2008 Data Channel MTU parms [ L:1544 D:1450 EF:44 EB:135 ET:
    0 EL:0 AF:3/1 ]
    Sat Oct 04 21:04:34 2008 Local Options hash (VER=V4): '69109d17'
    Sat Oct 04 21:04:34 2008 Expected Remote Options hash (VER=V4): 'c0103fa8'
    Sat Oct 04 21:04:34 2008 Attempting to establish TCP connection with 207.96.XXX.
    XXX:1194
    Sat Oct 04 21:04:34 2008 TCP connection established with 207.96.XXX.XXX:1194
    Sat Oct 04 21:04:34 2008 TCPv4_CLIENT link local: [undef]
    Sat Oct 04 21:04:34 2008 TCPv4_CLIENT link remote: 207.96.XXX.XXX:1194
    Sat Oct 04 21:04:34 2008 TLS: Initial packet from 207.96.XXX.XXX:1194, sid=745f1
    354 c24268b3

    Sat Oct 04 21:04:35 2008 Data Channel Encrypt: Cipher 'BF-CBC' initialized with
    128 bit key
    Sat Oct 04 21:04:35 2008 Data Channel Encrypt: Using 160 bit message hash 'SHA1'
    for HMAC authentication
    Sat Oct 04 21:04:35 2008 Data Channel Decrypt: Cipher 'BF-CBC' initialized with
    128 bit key
    Sat Oct 04 21:04:35 2008 Data Channel Decrypt: Using 160 bit message hash 'SHA1'
    for HMAC authentication
    Sat Oct 04 21:04:35 2008 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES2
    56-SHA, 1024 bit RSA
    Sat Oct 04 21:04:35 2008 [server] Peer Connection Initiated with 207.96.XXX.XXX:
    1194
    Sat Oct 04 21:04:36 2008 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
    Sat Oct 04 21:04:37 2008 PUSH: Received control message: 'PUSH_REPLY,route 192.1
    68.1.1 255.255.255.0,dhcp-option DISABLE-NBT,route 192.168.200.1,ping 10,ping-re
    start 60,ifconfig 192.168.200.6 192.168.200.5'
    Sat Oct 04 21:04:37 2008 OPTIONS IMPORT: timers and/or timeouts modified
    Sat Oct 04 21:04:37 2008 OPTIONS IMPORT: –ifconfig/up options modified
    Sat Oct 04 21:04:37 2008 OPTIONS IMPORT: route options modified
    Sat Oct 04 21:04:37 2008 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options
    modified
    Sat Oct 04 21:04:37 2008 TAP-WIN32 device [OVPN] opened: \.\Global{2198D7B9-21
    6A-48CC-A379-A37698EBE8B8}.tap
    Sat Oct 04 21:04:37 2008 TAP-Win32 Driver Version 8.4
    Sat Oct 04 21:04:37 2008 TAP-Win32 MTU=1500
    Sat Oct 04 21:04:37 2008 Notified TAP-Win32 driver to set a DHCP IP/netmask of 1
    92.168.200.6/255.255.255.252 on interface {2198D7B9-216A-48CC-A379-A37698EBE8B8}
    [DHCP-serv: 192.168.200.5, lease-time: 31536000]
    Sat Oct 04 21:04:37 2008 Successful ARP Flush on interface [65542] {2198D7B9-216
    A-48CC-A379-A37698EBE8B8}
    Sat Oct 04 21:04:37 2008 TEST ROUTES: 0/0 succeeded len=2 ret=0 a=0 u/d=down
    Sat Oct 04 21:04:37 2008 Route: Waiting for TUN/TAP interface to come up…
    Sat Oct 04 21:04:38 2008 TEST ROUTES: 0/0 succeeded len=2 ret=0 a=0 u/d=down
    Sat Oct 04 21:04:38 2008 Route: Waiting for TUN/TAP interface to come up...
    Sat Oct 04 21:04:39 2008 TEST ROUTES: 0/0 succeeded len=2 ret=0 a=0 u/d=down
    Sat Oct 04 21:04:39 2008 Route: Waiting for TUN/TAP interface to come up...
    Sat Oct 04 21:04:40 2008 TEST ROUTES: 0/0 succeeded len=2 ret=0 a=0 u/d=down
    Sat Oct 04 21:04:40 2008 Route: Waiting for TUN/TAP interface to come up...
    Sat Oct 04 21:04:41 2008 TEST ROUTES: 2/2 succeeded len=2 ret=1 a=0 u/d=up
    Sat Oct 04 21:04:41 2008 route ADD 192.168.1.1 MASK 255.255.255.0 192.168.200.5
    Sat Oct 04 21:04:41 2008 Warning: address 192.168.1.1 is not a network address i
    n relation to netmask 255.255.255.0
    Sat Oct 04 21:04:41 2008 ROUTE: route addition failed using CreateIpForwardEntry
    : The parameter is incorrect.  [if_index=65542]
    Sat Oct 04 21:04:41 2008 Route addition via IPAPI failed
    Sat Oct 04 21:04:41 2008 route ADD 192.168.200.1 MASK 255.255.255.255 192.168.20
    0.5
    Sat Oct 04 21:04:41 2008 Route addition via IPAPI succeeded
    Sat Oct 04 21:04:41 2008 Initialization Sequence Completed



  • Can you be more specific about your setup?
    (a diagram what you have where, with the IP-ranges)
    Also please provide the config-files of the server and the client.
    http://forum.pfsense.org/index.php/topic,7001.0.html



  • With pleasure!

    My rooter IP is 192.168.1.1

    Thank you for the help!

    ![OpenVPN_ Server.jpg](/public/imported_attachments/1/OpenVPN_ Server.jpg)
    ![OpenVPN_ Server.jpg_thumb](/public/imported_attachments/1/OpenVPN_ Server.jpg_thumb)





  • @GruensFroeschli:

    Also please provide the config-files of the server and the client.
    http://forum.pfsense.org/index.php/topic,7001.0.html

    Mostly the file of the client since you seem to have missconfigured something there.


Log in to reply